Opened 9 years ago

Closed 9 years ago

#33184 closed defect (worksforme)

poppler V 0.28 not installing on Mac 10.6.8

Reported by: antineu.llnl@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: dbevans (David B. Evans)
Port: poppler

Description (last modified by ryandesign (Ryan Schmidt))

I was trying to install texlive-latex-recommended (and all other texlive downloads) and got an error which I traced to the following underlying problem:

bash-3.2# port install poppler
--->  Computing dependencies for poppler
--->  Fetching archive for poppler
--->  Attempting to fetch poppler-0.18.2_0.darwin_10.x86_64.tbz2 from http://packages.macports.org/poppler
--->  Fetching poppler
--->  Verifying checksum(s) for poppler
--->  Extracting poppler
--->  Configuring poppler
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Log for poppler is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
  • I have already checked (re-installed) XCode and I am running version 3.2.4
  • I have searched the wells of the MacPort logs and have tried to implement many of the previous resolves for similar issues.
    • port selfupdate
    • port upgrade outdated
    • port clean poppler
    • port install poppler

-- I then received the same error as above.

  • I am attaching the log file for this error.

I would appreciate any help you can provide in this matter.

Attachments (1)

poppler-main.log (3.0 KB) - added by antineu.llnl@… 9 years ago.
poppler-main.log

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by antineu.llnl@…

Attachment: poppler-main.log added

poppler-main.log

comment:1 Changed 9 years ago by antineu.llnl@…

Cc: antineu.llnl@… added

Cc Me!

comment:2 Changed 9 years ago by antineu.llnl@…

This is a problem with the poppler code as I was able to install all my updates to texlive using:

sudo port -np install texlive-science

with no problems.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… added; antineu.llnl@… removed
Description: modified (diff)
Port: poppler added

The log you attached is not from the output you showed above. The output you showed above ends with an error in the configure phase, but the relevant error in the log you attached is from the fetch phase:

:info:archivefetch --->  poppler-0.18.2_0.darwin_10.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/software/poppler
:msg:archivefetch --->  Attempting to fetch poppler-0.18.2_0.darwin_10.x86_64.tbz2 from http://packages.macports.org/poppler
:msg:archivefetch --->  Attempting to fetch poppler-0.18.2_0.darwin_10.x86_64.tbz2.rmd160 from http://packages.macports.org/poppler
:debug:archivefetch failed verification with key /opt/local/share/macports/macports-pubkey.pem
:debug:archivefetch openssl output: Verification Failure
child process exited abnormally
:error:archivefetch Target org.macports.archivefetch returned: Failed to verify signature for archive!

Please attach the main.log that corresponds with the output you pasted above, or if the archive verification is the failure you're still experiencing, then we need to debug why that's happening.

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

antineu.llnl, can you please provide more information about this problem, as I requested above, so that we can begin to try to help you resolve it?

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Closing due to lack of response.

Note: See TracTickets for help on using tickets.