Opened 7 years ago

Closed 7 years ago

#33422 closed defect (duplicate)

apple-gcc42 on Tiger; File not found - build failure

Reported by: kurn@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: tiger Cc:
Port: apple-gcc42

Description

apple-gcc42 trying to install on Tiger. Build fails. The key message seems to be "can't locate file for: -ldylib1.10.5.o" Please, find log file attached.

Attachments (1)

main.log (1.1 MB) - added by kurn@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by kurn@…

Attachment: main.log added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jeremyhu removed
Keywords: tiger added
Owner: changed from macports-tickets@… to jeremyhu@…

Other problems (#32127) have been reported against apple-gcc42 on Tiger before, and I get the impression that the maintainer will not be addressing them, since he has no access to a Tiger machine anymore and Tiger is ancient by now. Upgrade your OS to Leopard or Snow Leopard, and upgrade Xcode to the correspondingly required version, to get a newer version of Apple GCC. Or use the FSF versions of GCC available in MacPorts in the ports gcc46, gcc45, gcc44, etc.

Note that the Cc field must contain complete email addresses.

comment:2 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: duplicate
Status: newclosed

Yeah, let's consolidate the apple-gcc42 tiger bug reports.

Dupe of: #32127

Note: See TracTickets for help on using tickets.