Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#34135 closed defect (fixed)

openssl: compile failure on PPC darwin 9

Reported by: blair (Blair Zajac) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.0.4
Keywords: Cc: tenomoto (Takeshi Enomoto), ned-deily (Ned Deily), jmroot (Joshua Root), danielluke (Daniel J. Luke), skymoo (Adam Mercer), mac@…, pixilla (Bradley Giesbrecht), kenyon@…, grego.tws@…, tascafoo@…, hosseini@…, razzfazz@…, ballapete (Peter Dyballa)
Port: openssl

Description

Hello,

The recent upgrades to openssl fail to compile on my lowly PowerBook. I've copied the end of the build here. Even trying with or without no-asm the compile fails. I can provide more info or help if needed.

Blair

ranlib: file: ../../libcrypto.a(ebcdic.o) has no symbols
ranlib: file: ../../libcrypto.a(fips_ers.o) has no symbols
ranlib: file: ../../libcrypto.a(ecp_nistp224.o) has no symbols
ranlib: file: ../../libcrypto.a(ecp_nistp256.o) has no symbols
ranlib: file: ../../libcrypto.a(ecp_nistp521.o) has no symbols
ranlib: file: ../../libcrypto.a(ecp_nistputil.o) has no symbols
ranlib: file: ../../libcrypto.a(rand_win.o) has no symbols
ranlib: file: ../../libcrypto.a(rand_os2.o) has no symbols
ranlib: file: ../../libcrypto.a(rand_nw.o) has no symbols
ranlib: file: ../../libcrypto.a(e_rc5.o) has no symbols
ranlib: file: ../../libcrypto.a(m_md2.o) has no symbols
ranlib: file: ../../libcrypto.a(evp_fips.o) has no symbols
ranlib: file: ../../libcrypto.a(v3_asid.o) has no symbols
ranlib: file: ../../libcrypto.a(v3_addr.o) has no symbols
/usr/bin/ranlib ../../libcrypto.a || echo Never mind.
/usr/bin/ranlib: file: ../../libcrypto.a(ebcdic.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(fips_ers.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistp224.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistp256.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistp521.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistputil.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(rand_win.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(rand_os2.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(rand_nw.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(e_rc5.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(m_md2.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(evp_fips.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(v3_asid.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(v3_addr.o) has no symbols
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.1a/crypto/cmac'
if [ -n "libcrypto.1.0.0.dylib libssl.1.0.0.dylib" ]; then \
		(cd ..; /usr/bin/make libcrypto.1.0.0.dylib); \
	fi
make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.1a'
[ -z "" ] || /usr/bin/gcc-4.2 -fPIC -fno-common -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -arch ppc -O3 -DB_ENDIAN -Wa,-force_cpusubtype_ALL -DOPENSSL_BN_ASM_MONT -DSHA1_ASM -DSHA256_ASM -DAES_ASM -Iinclude \
		-DFINGERPRINT_PREMAIN_DSO_LOAD -o fips_premain_dso  \
		fips_premain.c fipscanister.o \
		libcrypto.a -L/opt/local/lib  -lz
make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.1a'
make[4]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_openssl/openssl/work/openssl-1.0.1a'
Undefined symbols:
  "_OPENSSL_ia32cap_P", referenced from:
      _OPENSSL_ia32cap_P$non_lazy_ptr in libcrypto.a(e_rc4_hmac_md5.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[4]: *** [link_a.darwin] Error 1

Attachments (2)

patch-openssl-1.0.1a-patchset_22455.diff (88.2 KB) - added by pixilla (Bradley Giesbrecht) 5 years ago.
Adds openssl.org openssl_patchset_22455.diff patch, cleans up existing patches and revbumps.
patch-min-openssl-1.0.1a-patchset_22455.diff (2.3 KB) - added by pixilla (Bradley Giesbrecht) 5 years ago.
This patch only adds the openssl.org openssl_patchset_22455.diff patch. This patch does not clean up the "Hunk" warnings present in the existing openssl patches. Produce the same patched sources as my previously uploaded patch-openssl-1.0.1a-patchset_22455.diff patch.

Download all attachments as: .zip

Change History (28)

comment:1 Changed 5 years ago by tenomoto (Takeshi Enomoto)

  • Cc takeshi@… added

Cc Me!

comment:2 Changed 5 years ago by ned-deily (Ned Deily)

  • Cc nad@… added

Cc Me!

comment:3 Changed 5 years ago by jmroot (Joshua Root)

  • Cc jmr@… added

comment:4 Changed 5 years ago by danielluke (Daniel J. Luke)

  • Cc dluke@… added

Cc Me!

comment:5 follow-up: Changed 5 years ago by jmroot (Joshua Root)

comment:6 in reply to: ↑ 5 ; follow-up: Changed 5 years ago by danielluke (Daniel J. Luke)

Replying to jmr@…:

http://cvs.openssl.org/chngview?cn=22455

The build succeeds and test suite reports "ALL TESTS SUCCESSFUL" with that patch applied (on my darwin 9/ppc box)

comment:7 Changed 5 years ago by skymoo (Adam Mercer)

  • Cc ram@… added

Cc Me!

comment:8 Changed 5 years ago by mac@…

  • Cc mac@… added

Cc Me!

comment:9 in reply to: ↑ 6 Changed 5 years ago by pixilla (Bradley Giesbrecht)

Replying to dluke@…:

Replying to jmr@…:

http://cvs.openssl.org/chngview?cn=22455

The build succeeds and test suite reports "ALL TESTS SUCCESSFUL" with that patch applied (on my darwin 9/ppc box)

This patch works for me on darwin 9/ppc and darwin 10/intel.

Changed 5 years ago by pixilla (Bradley Giesbrecht)

Adds openssl.org openssl_patchset_22455.diff patch, cleans up existing patches and revbumps.

comment:10 Changed 5 years ago by pixilla (Bradley Giesbrecht)

My testing indicates the patch works with darwin 11 as well. No regression. Let's implement it!

comment:11 Changed 5 years ago by pixilla (Bradley Giesbrecht)

  • Cc pixilla@… added

Cc Me!

comment:12 Changed 5 years ago by kenyon@…

  • Cc kenyon@… added

Cc Me!

comment:13 follow-up: Changed 5 years ago by grego.tws@…

Hi,

I am new to all of this (Macports, Mac OS X). I have Snow Leopard 10.6.8 on Mac Book Pro, i tried to execute "sudo port -d install openssl +universal" in Terminal but got the described error. I don't know how to get/update/install the provided patch to Macports. May i ask for some help ?

comment:14 Changed 5 years ago by grego.tws@…

  • Cc grego.tws@… added

Cc Me!

comment:15 in reply to: ↑ 13 ; follow-up: Changed 5 years ago by danielluke (Daniel J. Luke)

Replying to grego.tws@…:

I am new to all of this (Macports, Mac OS X). I have Snow Leopard 10.6.8 on Mac Book Pro, i tried to execute "sudo port -d install openssl +universal" in Terminal but got the described error.

If you don't actually need +universal, you should just install without it (and you may want to check and see if ppc is one of your universal archs, you may not actually need/want it).

I don't know how to get/update/install the provided patch to Macports. May i ask for some help ?

You wait for the maintainer to update the port, then you sync/selfupdate and try again.

Changed 5 years ago by pixilla (Bradley Giesbrecht)

This patch only adds the openssl.org openssl_patchset_22455.diff patch. This patch does not clean up the "Hunk" warnings present in the existing openssl patches. Produce the same patched sources as my previously uploaded patch-openssl-1.0.1a-patchset_22455.diff patch.

comment:16 Changed 5 years ago by tascafoo@…

  • Cc tascafoo@… added

Cc Me!

comment:17 in reply to: ↑ 15 ; follow-up: Changed 5 years ago by grego.tws@…

Replying to dluke@…:

If you don't actually need +universal, you should just install without it (and you may want to check and see if ppc is one of your universal archs, you may not actually need/want it).

I installed openssl w/o universal variant but the software that need it still does not recognize libcrypto.1.0.0.dylib. I was asked to try installing openssl with +universal variant. How do i check if "ppc is one of my universal archs" ? Ty

comment:18 in reply to: ↑ 17 Changed 5 years ago by danielluke (Daniel J. Luke)

Replying to grego.tws@…:

I installed openssl w/o universal variant but the software that need it still does not recognize libcrypto.1.0.0.dylib. I was asked to try installing openssl with +universal variant. How do i check if "ppc is one of my universal archs" ?

Trac is for bug reports, if you want support try the macports-users mailing list.

comment:19 Changed 5 years ago by grego.tws@…

You're right ! My apologies...

comment:20 Changed 5 years ago by hosseini@…

  • Cc hosseini@… added

Cc Me!

comment:21 Changed 5 years ago by razzfazz@…

  • Cc razzfazz@… added

Cc Me!

comment:22 Changed 5 years ago by jmroot (Joshua Root)

  • Resolution set to fixed
  • Status changed from new to closed

r92268 (maintainer timeout)

comment:23 Changed 5 years ago by ballapete (Peter Dyballa)

  • Resolution fixed deleted
  • Status changed from closed to reopened

I started to upgrade packages on Tiger, 10.4.11, PPC. The package openssl-1.0.1a does not build here with GCC 4.0 (GCC 4.2 is available):

/usr/bin/ranlib ../../libcrypto.a || echo Never mind.
/usr/bin/ranlib: file: ../../libcrypto.a(ebcdic.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(fips_ers.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistp224.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistp256.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistp521.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(ecp_nistputil.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(rand_win.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(rand_os2.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(rand_nw.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(e_rc5.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(m_md2.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(evp_fips.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(v3_asid.o) has no symbols
/usr/bin/ranlib: file: ../../libcrypto.a(v3_addr.o) has no symbols
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a/crypto/cmac'
if [ -n "libcrypto.1.0.0.dylib libssl.1.0.0.dylib" ]; then \
	(cd ..; /usr/bin/make libcrypto.1.0.0.dylib); \
fi
make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a'
[ -z "" ] || /usr/bin/gcc-4.0 -fPIC -fno-common -DOPENSSL_PIC -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -arch ppc -O3 -DB_ENDIAN -Wa,-force_cpusubtype_ALL -Iinclude \
	-DFINGERPRINT_PREMAIN_DSO_LOAD -o fips_premain_dso  \
	fips_premain.c fipscanister.o \
	libcrypto.a -L/opt/local/lib  -lz
make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a'
make[4]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a'
Undefined symbols:
  "_OPENSSL_ia32cap_P", referenced from:
      _OPENSSL_ia32cap_P$non_lazy_ptr in libcrypto.a(e_rc4_hmac_md5.o)
ld: symbol(s) not found
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: internal link edit command failed
make[4]: *** [link_a.darwin] Error 1
make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/work/openssl-1.0.1a'

The patch files mentioned have not yet arrived:

l lil.fr.rsync.macports.org/release/tarballs/ports/devel/openssl/files/
total 32
-rw-r--r--   1 root  wheel   645 16 Feb 06:25 patch-Configure.diff
-rw-r--r--   1 root  wheel   506  8 Jul  2010 patch-Makefile.org.diff
-rw-r--r--   1 root  wheel  1487 19 Sep  2011 patch-bn_internal.pod.diff
-rw-r--r--   1 root  wheel   504  2 Feb  2009 patch-crypto-Makefile.diff

comment:24 Changed 5 years ago by ballapete (Peter Dyballa)

  • Cc Peter_Dyballa@… added

Cc Me!

comment:25 Changed 5 years ago by jmroot (Joshua Root)

  • Resolution set to fixed
  • Status changed from reopened to closed

If the patch file isn't present, then you have a problem with syncing. It's there for me on a machine that syncs with rsync.

comment:26 Changed 5 years ago by jmroot (Joshua Root)

Or actually, the mirror you use probably just hasn't synced with the master yet.

Note: See TracTickets for help on using tickets.