Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#34134 closed defect (fixed)

webkit-gtk @1.6.3 - Build failure

Reported by: l.wayne.james@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.0.99
Keywords: haspatch Cc: macports1@…
Port: webkit-gtk

Description

I am trying to build webkit-gtk as a pre-requisite to gimp2.

Variants: (+)quartz, [+]svg, (-)universal, [+]video

Build is failing with:

  CXX    Source/WebCore/platform/gtk/libWebCoreGtk_la-GeolocationServiceGtk.lo
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp:27:30: error: cairo/cairo-xlib.h: No such file or directory
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp:29:22: error: gdk/gdkx.h: No such file or directory
  CXX    Source/WebCore/platform/gtk/libWebCoreGtk_la-GOwnPtrGtk.lo
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp: In constructor 'WebCore::WidgetBackingStorePrivate::WidgetBackingStorePrivate(GtkWidget*, const WebCore::IntSize&)':
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp:62: error: 'GDK_SCREEN_XDISPLAY' was not declared in this scope
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp:64: error: 'GDK_WINDOW_XID' was not declared in this scope
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp:70: error: 'GDK_VISUAL_XVISUAL' was not declared in this scope
Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp:71: error: 'cairo_xlib_surface_create' was not declared in this scope
make[1]: *** [Source/WebCore/platform/gtk/libWebCoreGtk_la-GtkWidgetBackingStoreX11.lo] Error 1

Log is attached.

Attachments (4)

main.log.bz2 (12.7 KB) - added by l.wayne.james@… 7 years ago.
Build log
quartz.patch (1.6 KB) - added by l.wayne.james@… 7 years ago.
Patch to move "Source/WebCore/plugins/gtk/PluginViewGtk.cpp" into X11 build section
quartz.2.patch (1.1 KB) - added by l.wayne.james@… 7 years ago.
"quartz.patch" produced by diff -u
quartz-regression.patch (1.3 KB) - added by pokui@… 7 years ago.
patches both the portfile and adds the quartz.patch so needs -p0 and to be run a dir above the port dir

Download all attachments as: .zip

Change History (22)

Changed 7 years ago by l.wayne.james@…

Attachment: main.log.bz2 added

Build log

comment:1 Changed 7 years ago by l.wayne.james@…

Cc: l.wayne.james@… added

Cc Me!

comment:2 Changed 7 years ago by l.wayne.james@…

Changes from ticket #34086 had no effect.

comment:3 in reply to:  2 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from macports-tickets@… to jeremyhu@…
Status: newassigned

Replying to l.wayne.james@…:

Changes from ticket #34086 had no effect.

Well, they did have an effect. The effect was that they got past that issue and got you to a new one...

Apparently, it's trying to bring in some X11 related bits when it shouldn't...

comment:4 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

comment:5 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: assignedclosed

r92147 should address this one... hopefully that's the last one...

comment:6 in reply to:  5 Changed 7 years ago by l.wayne.james@…

Resolution: fixed
Status: closedreopened

Replying to jeremyhu@…:

r92147 should address this one... hopefully that's the last one...

Unfortunately - in my case - it wasn't. :)

But removing "Source/WebCore/plugins/gtk/PluginViewGtk.cpp" as you did "GtkWidgetBackingStoreX11.cpp" allowed a complete build.

Please forgive my ignorance, but do you wish me to open another ticket for tracking purposes? or would a new (quartz.patch) patch attached to this one help?

I'll be able to do either (I think) as soon as gimp builds and I can confirm basic functionality.

By the way... Thank you! :D

comment:7 Changed 7 years ago by l.wayne.james@…

Attaching new "quartz.patch" as promised. This allows webkit-gtk to build.

Changed 7 years ago by l.wayne.james@…

Attachment: quartz.patch added

Patch to move "Source/WebCore/plugins/gtk/PluginViewGtk.cpp" into X11 build section

comment:8 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: l.wayne.james@… removed
Keywords: haspatch added

We would prefer unified diffs instead of contextual ones.

comment:9 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: macports1@… added

Has duplicate #34139.

Changed 7 years ago by l.wayne.james@…

Attachment: quartz.2.patch added

"quartz.patch" produced by diff -u

comment:10 Changed 7 years ago by l.wayne.james@…

As you wish! :)

comment:11 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: reopenedclosed

Ok, I updated it with your patch. Thanks for the help. remote debugging has massive I/O lag. =)

r92162

Changed 7 years ago by pokui@…

Attachment: quartz-regression.patch added

patches both the portfile and adds the quartz.patch so needs -p0 and to be run a dir above the port dir

comment:12 Changed 7 years ago by pokui@…

Resolution: fixed
Status: closedreopened

r96758 added this bug back as a regression. Source/WebCore/plugins/gtk/PluginViewGtk.cpp still depends on X11.

ps: Midway my testing the patch r96855 was released without a rev bump ... made patching this interesting.

comment:13 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: reopenedclosed

Sorry. I thought upstream had already applied the patch. It's back in r96886

comment:14 Changed 7 years ago by daitakahashi

Could you include this small fix on quartz.patch, which resolves #35767?

@@ -10,7 +10,7 @@
  
  if TARGET_X11
  webcoregtk_sources += \
-+	Source/WebCore/plugins/gtk/PluginViewGtk.cpp
++	Source/WebCore/plugins/gtk/PluginViewGtk.cpp \
  	Source/WebCore/platform/gtk/GtkWidgetBackingStoreX11.cpp \
  	Source/WebCore/plugins/gtk/gtk2xtbin.c \
  	Source/WebCore/plugins/gtk/gtk2xtbin.h \

comment:15 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

<

r96926

comment:16 Changed 5 years ago by info@…

Resolution: fixed
Status: closedreopened

Not sure if I should reopen this or file another.

I got this error on build of webkit-gtk-2.0 (OSX 10.7.5, Intel Core i7):

--->  Configuring webkit-gtk-2.0
--->  Building webkit-gtk-2.0
Error: org.macports.build for port webkit-gtk-2.0 returned: command execution failed
Please see the log file for port webkit-gtk-2.0 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk-2.0/webkit-gtk-2.0/main.log

In the log:

:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk-2.0/webkit-gtk-2.0/work/webkitgtk-2.0.4" && /usr/bin/make -j8 -w all CC="/usr/bin/clang -arch x86_64" V=1 
:info:build Exit code: 2

Then trying to execute the failed command manually, a series of errors like this:

error: unable to open output file 'Source/JavaScriptCore/API/.libs/libjavascriptcoregtk_1_0_la-JSCallbackFunction.o': 'Error opening output file
      'Source/JavaScriptCore/API/.libs/libjavascriptcoregtk_1_0_la-JSCallbackFunction.o''

Turns out the /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk-2.0/webkit-gtk-2.0/work/webkitgtk-2.0.4/Source/JavaScriptCore/API/.libs directory doesn't exists

Creating the directory appears to have let it pass this step.

comment:17 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: reopenedclosed

File another please. This is a year and a half old bug ;)

comment:18 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Looks like a parallel build issue, fwiw... nothing to do with this bug.

Note: See TracTickets for help on using tickets.