Opened 7 years ago

Closed 7 years ago

#34926 closed defect (fixed)

webkit-gtk @1.6.3 rev.4 - build fails on case-sensitive HFS+ volume

Reported by: alexey.n@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: haspatch Cc: dbevans (David B. Evans), ryandesign (Ryan Schmidt)
Port: webkit-gtk

Description

I have MacPorts 2.1.1 on Mac OS X 10.5.8 which is installed on case-sensitive HFS+ volume.

Installation of webkit-gtk @1.6.3 rev.4 fails with the following message:

--->  Applying glib-2.32.patch
patching file Source/JavaScriptCore/wtf/gobject/GOwnPtr.h
Error: reinplace: couldn't read file "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/work/webkit-1.6.3/GNUMakefile.am": no such file or directory

The problem is in the Portfile's post-patch section:

post-patch {
    # Fix for newer autotools:
    # http://www.gnu.org/software/automake/manual/html_node/Obsolete-Macros.html
    reinplace "s/mkdir_p/MKDIR_P/" \
        ${worksrcpath}/GNUMakefile.am \
        ${worksrcpath}/Source/WebKit/gtk/po/GNUmakefile.am
}

73rd line of the Portfile is:

${worksrcpath}/GNUMakefile.am \

but should be:

${worksrcpath}/GNUmakefile.am \

Build process completed without errors after I fixed this line manually.

Change History (1)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… ryandesign@… added
Keywords: haspatch added
Resolution: fixed
Status: newclosed

Thanks for reporting the problem and the fix. Committed in r94433.

Note: See TracTickets for help on using tickets.