Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#35969 closed enhancement (fixed)

py-goocanvas: adding license and correcting indentation in Portfile

Reported by: cawka (Alex Afanasyev) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc:
Port: py-goocanvas

Description

The attached Portfile fixes indentation in Portfile and adds license GPL-2+

Attachments (5)

Portfile (2.2 KB) - added by cawka (Alex Afanasyev) 7 years ago.
Portfile
Portfile-add-license.patch (413 bytes) - added by cawka (Alex Afanasyev) 7 years ago.
Portfile-white-space-changes.patch (4.1 KB) - added by cawka (Alex Afanasyev) 7 years ago.
patch-only-whitespace.diff (3.9 KB) - added by cawka (Alex Afanasyev) 7 years ago.
patch-depends-build.diff (590 bytes) - added by cawka (Alex Afanasyev) 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by cawka (Alex Afanasyev)

Attachment: Portfile added

Portfile

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Keywords: maintainer added
Type: defectenhancement
Version: 2.1.2

Please attach a unified diff of the current Portfile from svn. We prefer to have whitespace changes be in a separate patch from the functional changes. So attaching two patches would be preferred.

Changed 7 years ago by cawka (Alex Afanasyev)

Attachment: Portfile-add-license.patch added

Changed 7 years ago by cawka (Alex Afanasyev)

comment:2 Changed 7 years ago by cawka (Alex Afanasyev)

Uploaded two unified patches. I didn't not change port's revision, since port functionality didn't change and there is no need for users to reinstall the port.

comment:3 Changed 7 years ago by drkp (Dan Ports)

Keywords: haspatch added
Owner: changed from macports-tickets@… to dports@…
Status: newassigned

comment:4 Changed 7 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Thanks, committed in r97455 and r97456.

The whitespace patch actually did change the port's revision, so I left that part out.

comment:5 Changed 7 years ago by drkp (Dan Ports)

Resolution: fixed
Status: closedreopened

Wait, there were functional changes in the whitespace patch. They don't seem right, so I reverted it in r97457.

Among other things, it adds subports for python 2.4, 2.5, 3.1, and 3.2 that are broken. For most of those, the problem is that there's no corresponding version of py-gtk. (There's a different issue for the py25 subport, probably related to MacPorts's python 2.5 not being a framework build, though really I wouldn't go to too much effort trying to support such an old version of Python unless there's an unusually compelling reason to do so.)

comment:6 Changed 7 years ago by cawka (Alex Afanasyev)

oops. Didn't mean to do that. Diffed with my old Portfile version by accident. Attaching two more patches, one only for whitespace (and small reorganization), another one with small functional change (depends_build replaced with depends_build-append). Also, I'm not sure whether pkgconfig dependency is automatically selected with "use_configure yes" or not.

Changed 7 years ago by cawka (Alex Afanasyev)

Attachment: patch-only-whitespace.diff added

Changed 7 years ago by cawka (Alex Afanasyev)

Attachment: patch-depends-build.diff added

comment:7 Changed 7 years ago by drkp (Dan Ports)

Resolution: fixed
Status: reopenedclosed

Looks good. r97653 and r97654.

Note: See TracTickets for help on using tickets.