Opened 8 years ago

Closed 7 years ago

#36773 closed defect (worksforme)

glib2 @2.34.1 configure failure: "cannot run C compiled programs"

Reported by: haidarz1994@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: glib2

Description

Last login: Sun Oct 28 14:45:51 on ttys000
dexter:~ Haidar$ sudo port install glib2
Password:
--->  Computing dependencies for glib2
--->  Configuring glib2
Error: org.macports.configure for port glib2 returned: configure failure: command execution failed
Please see the log file for port glib2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_glib2/glib2/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port glib2 failed
dexter:~ Haidar$ 

I was initially going to install "zenity" and it requested to install several items.One of these items glib2,but it failed. I tried every available method to find the responsible cause,but nothing happened. So please help.

Attachments (1)

main.log (17.4 KB) - added by haidarz1994@… 8 years ago.
main.log

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by haidarz1994@…

Attachment: main.log added

main.log

comment:1 Changed 8 years ago by neverpanic (Clemens Lang)

Cc: haidarz1994@… removed
Keywords: glib2 removed
Owner: changed from macports-tickets@… to ryandesign@…

Has duplicate #36772, assigning to maintainer.

comment:2 Changed 8 years ago by neverpanic (Clemens Lang)

Please also attach /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_glib2/glib2/work/glib-2.34.1/config.log.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Could you please attach the config.log so that we can begin to investigate what the problem is?

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Summary: glib2 installation is interruptedglib2 @2.34.1 configure failure: "cannot run C compiled programs"

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Closing due to lack of response.

Note: See TracTickets for help on using tickets.