Opened 7 years ago

Last modified 7 months ago

#37203 reopened defect

xcircuit crashes when using tk +aqua

Reported by: watsodw Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: Stochasticus@…, daledouglas@…, anddam (Andrea D'Amore), cooljeanius (Eric Gallager), ken.mcglothlen@…, kurthindenburg (Kurt Hindenburg), SickTeddyBear, chrstphrchvz (Christopher Chavez)
Port: xcircuit

Description (last modified by mf2k (Frank Schima))

Installed xcircuit, but when I try to run it I get the following error:

dwwatson - /Users/dwwatson - 2 -->xcircuit
2012-12-04 13:37:23.768 wish[44904:60b] A call to OSACopyScriptingDefinition() by NSScriptSuiteRegistry returned an error. Is this application's OSAScriptingDefinition Info.plist entry valid? If its value is 'dynamic', is there an 'ascr'/'gsdf' Apple event handler registered?
2012-12-04 13:37:23.809 wish[44904:60b] MADLog - Screens: 
Segmentation fault

It's the same with xcircuit-devel, too. I have tcl @8.5.13_0+corefoundation+threads+universal installed.

Change History (29)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Cc: nomaintainer@… removed

In the future, please use WikiFormatting. Cc'ing nomaintainer is not useful since it does not go to anyone.

comment:2 Changed 7 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 in reply to:  description Changed 7 years ago by daledouglas@…

Replying to david.w.watson@…:

Installed xcircuit, but when I try to run it I get the following error:

dwwatson - /Users/dwwatson - 2 -->xcircuit
2012-12-04 13:37:23.768 wish[44904:60b] A call to OSACopyScriptingDefinition() by NSScriptSuiteRegistry returned an error. Is this application's OSAScriptingDefinition Info.plist entry valid? If its value is 'dynamic', is there an 'ascr'/'gsdf' Apple event handler registered?
2012-12-04 13:37:23.809 wish[44904:60b] MADLog - Screens: 
Segmentation fault

It's the same with xcircuit-devel, too. I have tcl @8.5.13_0+corefoundation+threads+universal installed.

I confirm the bug. I have not tried xcircuit-devel. For me, wish also crashes, and then xcircuit reports seg faults.

tcl @8.6.0_1+corefoundation+threads
xcircuit @3.7.44_0
Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 Changed 7 years ago by Stochasticus@…

Cc: Stochasticus@… added

Cc Me!

comment:5 Changed 7 years ago by Stochasticus@…

I'm getting the same problem, but with even less information. The installed version of wish8.6 crashes with a segmentation fault. Seems to be a recurring problem. The last time I had something like this I reinstalled macports after the upgrade to Mountain Lion and it worked again. I'm not sure that will work here as this is happening on a new MacBook pro that had macports and xcircuit installed recently.

comment:6 Changed 7 years ago by Stochasticus@…

I just wiped and reinstalled macports and xcircuit 3.7.44 just in case the order I'd done things with this new computer was wrong but I'm still getting the same crash from the version of wish 8.6 installed by the tcl/tk ports. Wish (huh...) I knew what happened to fix it when I reinstalled everything the last time this happened with xcircuit. Maybe this should be reported under tcl/tk rather than here.

comment:7 Changed 7 years ago by daledouglas@…

Cc: daledouglas@… added

Cc Me!

comment:8 Changed 6 years ago by daledouglas@…

This ticket doesn't seem to be making progress -- is there anything I can do? Would reporting this upstream (i.e., the x-circuit dev team, whoever they may be) help? Many thanks!

comment:9 in reply to:  8 Changed 6 years ago by larryv (Lawrence Velázquez)

Replying to daledouglas@…:

This ticket doesn't seem to be making progress -- is there anything I can do? Would reporting this upstream (i.e., the x-circuit dev team, whoever they may be) help? Many thanks!

Yes, you should probably report this upstream. You could also send a message to the macports-users mailing list; you’ll have a better chance of getting help from some Tcl/Tk-savvy folks.

comment:10 Changed 6 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

I see the very same issue and output on Arch system, it's offering tcl/Tk 8.6 as mp currently does. On a Debian system the dependency is set to tcl/Tk 8.5 and xcircuit runs fine, I'd say it's an incompatibility of xcircuit with 8.6, I see OpenBSD xcircuit port states tcl and tk has to be <8.6 .

I'm not sure if a tcl85 and tk85 set of ports has been discussed already, meanwhile you can revert tcl and tk to 8.5 and see if it works.

Reporting this upstream is recommended, the author may be willing to fix the software for usage with 8.6 or clearly state that he won't.

Last edited 6 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:11 Changed 6 years ago by anddam (Andrea D'Amore)

I mistakenly replied to this ticket rather than #30787, I see the reporter here already had 8.5.13 and his issue is different than mine anyway.

Since I've already poked the ticket: did any of you solve the issue on his own? Can you still reproduce the issue at all?

comment:12 Changed 6 years ago by anddam (Andrea D'Amore)

Please check ticket:30787#comment:13 and see if that solves the issue. That's just a workaround and not a fix.

comment:13 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:14 Changed 5 years ago by ken.mcglothlen@…

Cc: ken.mcglothlen@… added

Same results, over a year and a half since the bug was first reported. I get a segfault on xcircuit 3.7.50_1 and xcircuit-devel 3.8.40_1, running under OS X 10.9.3 (and tcl/tk 8.6.1).

Anyone had any success with this port yet?

Last edited 5 years ago by ken.mcglothlen@… (previous) (diff)

comment:15 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:16 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

The latest xcircuit 3.8.38 still crashes on Mavericks - not sure if I'll be able to debug it

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000050

VM Regions Near 0x50:
--> 
    __TEXT                 0000000104f82000-0000000104f86000 [   16K] r-x/rwx SM=COW  /opt/local/bin/wish8.6

comment:17 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x0000000000000050
0x0000000100379d6b in CmapRecForColormap ()
(gdb) bt
#0  0x0000000100379d6b in CmapRecForColormap ()
#1  0x000000010037a115 in XcmsCCCOfColormap ()
#2  0x0000000100322f33 in XAllocNamedColor ()
#3  0x000000010550a9bc in CvtStringToPixel ()
#4  0x000000010550aa5f in xc_alloccolor ()
#5  0x000000010550385e in build_app_database ()
#6  0x0000000105504250 in GUI_init ()
#7  0x0000000105509010 in xctcl_start ()
#8  0x000000010015c697 in TclNRRunCallbacks ()
#9  0x000000010015d8bb in TclEvalEx ()
#10 0x00000001001ee528 in Tcl_FSEvalFileEx ()
#11 0x00000001001ed33e in Tcl_EvalFile ()
#12 0x00000001001f431e in Tcl_SourceRCFile ()
#13 0x000000010002895c in Tk_MainEx ()
#14 0x0000000100003edb in main ()

I've tried building it --without-tcl and various other configure options, but it won't build - also tried the 3.9 branch w/o any luck

comment:18 in reply to:  16 ; Changed 5 years ago by anddam (Andrea D'Amore)

Replying to khindenburg@…:

The latest xcircuit 3.8.38 still crashes on Mavericks - not sure if I'll be able to debug it

Out of curiosity where are you getting 3.8.38 from? The stable branch is 3.7 while xcircuit-devel has been 3.8.40 (unstable) for more than a year.

comment:19 in reply to:  18 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Replying to and.damore@…:

Replying to khindenburg@…:

The latest xcircuit 3.8.38 still crashes on Mavericks - not sure if I'll be able to debug it

Out of curiosity where are you getting 3.8.38 from? The stable branch is 3.7 while xcircuit-devel has been 3.8.40 (unstable) for more than a year.

http://opencircuitdesign.com/xcircuit/ - I mistyped - it is 3.8.68

http://opencircuitdesign.com/xcircuit/archive/xcircuit-3.8.68.tgz

comment:20 Changed 5 years ago by anddam (Andrea D'Amore)

I confirm I can reproduce the issue with both 3.8.69 (now stable branch) and 3.9.20 (development) on Mavericks.

comment:21 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

The fix from http://www.opencircuitdesign.com/pipermail/magic-dev/2014/000641.html works

sudo port install tk +x11

I'll update the Portfile shortly

comment:22 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

comment:23 Changed 5 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: closedreopened

Let's keep this open until solved, forcing +x11 is a workaround.

comment:24 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Summary: xcircuit crashes on startupxcircuit crashes when using tk +aqua

comment:25 Changed 5 years ago by SickTeddyBear

Cc: amcgee@… added

Cc Me!

comment:26 in reply to:  23 ; Changed 7 months ago by chrstphrchvz (Christopher Chavez)

Replying to anddam:

Let's keep this open until solved, forcing +x11 is a workaround.

According to a mailing list post by xcircuit's author, xcircuit relies on "low-level X11/Xlib calls". Compared to other Tk apps, it sounds non-trivial for xcircuit to support Tk Aqua, since it isn't completely relying on Tk's abstractions of whichever windowing system is used. Does it still make sense to leave this ticket open if tk +x11 isn't really a workaround but rather a requirement?

Currently, xcircuit (if the require_active_variants restriction is removed) and xcircuit-devel can't even compile with tk +quartz mainly due to redefinition errors in Xlib.h.

comment:27 Changed 7 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:28 in reply to:  26 Changed 7 months ago by anddam (Andrea D'Amore)

Replying to chrstphrchvz:

Does it still make sense to leave this ticket open if tk +x11 isn't really a workaround but rather a requirement?

Considering the little interest in the ticket (two CC's in last five years) and the issues with Aqua I'd say it's safe to close.

comment:29 Changed 7 months ago by chrstphrchvz (Christopher Chavez)

In 13a73de8aa212e6358ae39e494ace887b3aa4f47/macports-ports (master):

xcircuit[-devel]: require +x11 variants of tk and cairo

Not compatible with tk +quartz
Copied from portfile for xcircuit
See #37203

Fixes #57666

Note: See TracTickets for help on using tickets.