Opened 8 years ago

Closed 4 years ago

#37231 closed defect (invalid)

Build script(s) expecting script tclIndex in the wrong place

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.1.2
Keywords: Cc: cooljeanius (Eric Gallager), deesto (John S. De Stefano Jr.)
Port:

Description

Some builds (such as DSDP) fail because port cannot find the script

/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex

On a clean install of Mountain Lion, XCode 4.5.2 this file is found instead at

/System/Library/Frameworks/Tk.framework/Versions/8.5/Resources/Scripts/tclIndex

Workarounds include pre-building a package that knows the right script location, or installing a version of TCL that places the script in the former spot.

Change History (6)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Component: portsbase
Keywords: tclIndex removed

The error message about tclIndex appears often, for reasons that I don't understand, but in my experience it is never the cause of the problem, but rather an unrelated error message that MacPorts displays additionally when something else has already gone wrong. If you have a port that fails to build, please file a normal bug report for that port so that we can investigate and fix that problem. Of course, we would also love to understand why the tclIndex error appears and fix it.

comment:2 Changed 8 years ago by jmroot (Joshua Root)

The tclIndex error is clearly caught, since we never get a backtrace with it at the top. The errorInfo is still set, though. Later, we catch a different error that must not cause errorInfo to be set, so what we print out is the message from the earlier (expected and caught) error.

comment:3 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:4 Changed 8 years ago by cooljeanius (Eric Gallager)

lol, I actually worked around this by actually putting tclIndex files in all of those places...

comment:5 Changed 8 years ago by deesto (John S. De Stefano Jr.)

Cc: deesto@… added

Cc Me!

comment:6 Changed 4 years ago by raimue (Rainer Müller)

Resolution: invalid
Status: newclosed

This is missing steps for reproduction. I fail to see how this is an issue with base and not individual ports. Maybe this was resolved with the inclusion of our own Tcl installation.

Note: See TracTickets for help on using tickets.