Opened 8 years ago

Last modified 7 years ago

#37280 new defect

winetricks: can't install vcrun2008

Reported by: michi_ca@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc:
Port: winetricks

Description

Mountain Lion 10.8.2 and wine 1.5.19 installed with Macports. Using winetricks i installed d3dx9, vcrun2003 and vcrun2005, but trying to install vcrun2008 I get:

Michi$ winetricks vcrun2008
Executing w_do_call vcrun2008
Executing load_vcrun2008
Executing mkdir -p /Users/Michi/Library/Caches/winetricks/vcrun2008
Using native,builtin override for following DLLs: msvcr90
Executing winetricks_early_wine regedit C:\windows\Temp\_vcrun2008\override-dll.reg
Executing wine vcredist_x86.exe
fixme:clusapi:GetNodeClusterState ((null),0x32ec44) stub!
fixme:advapi:DecryptFileA "y:\\404e660dd606196962\\" 00000000
err:ntdll:RtlpWaitForCriticalSection section 0x42cc4ab4 "win.c: surfaces_section" wait timed out in thread 0027, blocked by 0000, retrying (60 sec)
wine: Critical section 42cc4ab4 wait failed at address 0x7bc28049 (thread 0027), starting debugger...
Unhandled exception: wait failed on critical section 0x42cc4ab4 in 32-bit code (0x7bc28049).
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7bc28049
------------------------------------------------------
Note: command 'wine vcredist_x86.exe' returned status 148.  Aborting.
------------------------------------------------------
Process of pid=0025 has terminated
No process loaded, cannot execute 'echo Modules:'
Cannot get info on module while no process is loaded
No process loaded, cannot execute 'echo Threads:'
process  tid      prio (all id:s are in hex)
0000000e services.exe
   00000021    0
   00000020    0
   00000015    0
   00000010    0
   0000000f    0
MacBook-Pro-di-xxx-xxx:~ Michi$ 00000012 winedevice.exe
   0000001e    0
   0000001a    0
   00000014    0
   00000013    0
0000001b plugplay.exe
   00000022    0
   0000001f    0
   0000001c    0
00000023 explorer.exe
   00000024    0
winedbg: Internal crash at 0x401bfc4c

After complete uninstall/reinstall i tried installing vcrun2003 and vcrun 2005 and all was fine, but then again installing vcrun2008 (both from terminal or winetricks window) got this error

Change History (5)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Summary: can't install vcrun2008 on WINEwinetricks: can't install vcrun2008

Hmm, you might have to report this problem to the developer of winetricks; I don't know what to do about it, and all we do in MacPorts is install the winetricks script as provided by the developer, so I doubt the problem is MacPorts-specific.

comment:2 Changed 8 years ago by michi_ca@…

Will do. I tried also to dl the .exe from microsoft and install it with wine, but I'm getting pretty much the same error. Any other way to get the necessary DLLs installed?

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

I don't know... Last time I needed to do this kind of thing, which was awhile ago, winetricks just worked.

comment:4 Changed 8 years ago by michi_ca@…

Thank you anyway. The weird thing is it just used to work with my previous wine builds (based on 1.4.1 and 1.5.17)

Last edited 8 years ago by michi_ca@… (previous) (diff)

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

wine and winetricks have been updated since this ticket was filed; please try again.

Note: See TracTickets for help on using tickets.