Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#37303 closed defect (invalid)

When installing Wine, terminal replies Error: Port wine not found

Reported by: felipeans_13@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: dejesus2010@…
Port: wine

Description

Hello, I am new to Mac Ports and recently tried to install Wine on my MacBook to run some windows programs I hastily need. That being said, I followed this guide carefully http://www.davidbaumgold.com/tutorials/wine-mac/ but I found an impediment on the last step to install Wine.

The terminal replied:

M-s-MacBook:~ Usuario$ sudo port install wine
Warning: /opt/local/etc/macports/variants.conf specifies invalid variant syntax '?+universal?', ignored.
Error: Port wine not found

My Macbook information is Mac OS X version 10.5.8 Processor GHz Intel Core 2 Duo and a Toshiba startup disk. Already installed Xcode Tools, Java developer, XQuartz (X11-2.6.3), and MacPorts (2.1.2) all 4 for v. 10.5.x

I would really appreciate any assist and reply.

Change History (5)

comment:1 in reply to:  description ; Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: Wine Terminal Port not found removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: wine added

Replying to felipeans_13@…:

Warning: /opt/local/etc/macports/variants.conf specifies invalid variant syntax '?+universal?', ignored.

Apparently you've put something strange in your variants.conf and should fix that. Note that the part where those instructions have you put +universal in your variants.conf has not been necessary for a long time. You can just leave your variants.conf blank and it'll work fine. MacPorts knows when ports need to be installed universal and will do so automatically.

Error: Port wine not found

MacPorts thinks the wine port doesn't exist, but of course it does. Perhaps your ports tree is out of date or even missing. Try updating it by running:

sudo port selfupdate

Do this periodically to ensure you have the latest port definitions, then update any outdated ports by running:

sudo port upgrade outdated

comment:2 Changed 6 years ago by felipeans_13@…

Thank you Ryandesign, the problem was solved by updating the port tree. Afterwards Wine´s installation ran smoothly.

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Great! Hope you enjoy Wine.

The wine port contains the latest stable version of wine, but you may also want to try newer development versions, as wine is still under active development. To do so:

sudo port deactivate wine
sudo port install wine-devel

comment:4 in reply to:  1 ; Changed 6 years ago by dejesus2010@…

If the installation of wine stopped at wine_gecko-1.4-x86.msi and produced an error message:

Error: org.macports.configure for port wine returned: 
configure failure: command execution failed
Please see the log file for port wine for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_wine/wine/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

What should I do?

I have Xcode4.6, Xquartz, and Macports all installed so I am unsure to why I am receiving an error. How can I pick up from where the installation process left off?

Last edited 6 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:5 in reply to:  4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: dejesus2010@… added

Replying to dejesus2010@…:

What should I do?

File a new bug report or ask for help on the macports-users mailing list. This bug is closed and does not appear to be related to the problem you're experiencing.

Note: See TracTickets for help on using tickets.