Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#37516 closed defect (worksforme)

libsdl @1.2.15_2 +universal build failure - clang segfault

Reported by: bs1464@… Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: libsdl

Description

I have libsdl 1.2.15_0 and I have tried everything that was advised on the ticket guide, but no luck.

It fails during build. It cannot do some changig directory(?) according to the log. (Error: org.macports.build for port libsdl returned: command execution failed)

Attachments (3)

main.log (52.6 KB) - added by bs1464@… 8 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libsdl/libsdl/main.log
clang_2013-01-04-024211_localhost.crash (10.0 KB) - added by bs1464@… 8 years ago.
/Library/Logs/DiagnosticReports/clang_2013-01-04-024211_localhost.crash
main.2.log (544.0 KB) - added by bs1464@… 8 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_vxl/vxl/main.log

Download all attachments as: .zip

Change History (17)

Changed 8 years ago by bs1464@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libsdl/libsdl/main.log

comment:1 Changed 8 years ago by bs1464@…

My aim is to install vxl, not libsdl, so if I could just skip upgrading libsdl, that would be the best for me. Cheers.

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to jmr@…
Port: libsdl added

Please clean libsdl and try again. Also let us know what version of Xcode and clang you have. Find the Xcode version by getting info on the Xcode application; find the clang version by running "clang -v".

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Type: updatedefect

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Cc: jeremyhu@… added
Summary: Unable to upgrade to libsdl 1.2.15_2libsdl @1.2.15_2 +universal build failure - clang segfault

comment:5 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

And check if you have a crash report in /Library/Logs/DiagnosticReports that you can attach.

comment:6 Changed 8 years ago by bs1464@…

Thank you for looking into my problem!

clang -v returned:

clang version 3.1 (branches/release_31) Target: x86_64-apple-darwin11.4.2 Thread model: posix

my XCode version is 4.5.2 (4G2008a)

I have tried to clean libsdl and update many times, did not work. Is it normal that clang -v returned 3.1 while I normally compile with Apple LLVM 4.1?

Last edited 8 years ago by bs1464@… (previous) (diff)

comment:7 Changed 8 years ago by bs1464@…

Today for some reason now the following lines seemed to work:

cv /Library/Logs/DiagnosticReports
sudo port install libsdl
port clean libsdl
sudo port clean libsdl
sudo port install libsdl

After the last command I saw the following feedback:

---> Computing dependencies for libsdl
---> Fetching archive for libsdl
---> Attempting to fetch libsdl-1.2.15_2+x11.darwin_11.x86_64.tbz2 from http://lil.fr.packages.macports.org/libsdl
---> Attempting to fetch libsdl-1.2.15_2+x11.darwin_11.x86_64.tbz2.rmd160 from http://lil.fr.packages.macports.org/libsdl
---> Installing libsdl @1.2.15_2+x11
---> Deactivating libsdl @1.2.15_0+universal+x11

---> Cleaning libsdl
---> Activating libsdl @1.2.15_2+x11
---> Cleaning libsdl
---> Updating database of binaries: 100.0%
---> Scanning binaries for linking errors: 100.0%
---> No broken files found.

I have tried exactly the same two days ago and it did not work. Im not sure what made the difference. From my side you can close the ticket, I attach a chrashreport here if you wish to do further investigation.

Thanx Barna. :)

Last edited 8 years ago by bs1464@… (previous) (diff)

Changed 8 years ago by bs1464@…

/Library/Logs/DiagnosticReports/clang_2013-01-04-024211_localhost.crash

comment:8 in reply to:  7 Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to bs1464@…:

After the last command I saw the following feedback:

--->  Computing dependencies for libsdl
--->  Fetching archive for libsdl
--->  Attempting to fetch libsdl-1.2.15_2+x11.darwin_11.x86_64.tbz2 from http://lil.fr.packages.macports.org/libsdl
--->  Attempting to fetch libsdl-1.2.15_2+x11.darwin_11.x86_64.tbz2.rmd160 from http://lil.fr.packages.macports.org/libsdl
--->  Installing libsdl @1.2.15_2+x11

Your port didn't compile this time around; it fetched an archive and installed directly. Also note that it installed libsdl +x11, not libsdl +x11+universal.

comment:9 in reply to:  6 Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to bs1464@…:

clang -v returned:

clang version 3.1 (branches/release_31)
Target: x86_64-apple-darwin11.4.2
Thread model: posix

my XCode version is 4.5.2 (4G2008a)

I have tried to clean libsdl and update many times, did not work. Is it normal that clang -v returned 3.1 while I normally compile with Apple LLVM 4.1?

That doesn't look like Apple's clang. Can you run /usr/bin/clang -v?

comment:10 Changed 8 years ago by bs1464@…

Hang on, I must have used clang_select a while ago.
How can I change settings back to default? It seems to be the root cause of the problem, now vxl building also crashes.

btw. /usr/bin/clang -v reports:

Apple clang version 3.0 (tags/Apple/clang-211.12) (based on LLVM 3.0svn) Target: x86_64-apple-darwin11.4.2 Thread model: posix

Last edited 8 years ago by bs1464@… (previous) (diff)

comment:11 Changed 8 years ago by jmroot (Joshua Root)

That's a much older version than the one that comes with Xcode 4.5.2. Update your Command Line Tools via the Xcode preferences.

comment:12 Changed 8 years ago by bs1464@…

Yes, I did so. Now, my clang -v is

Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM 3.1svn)
Target: x86_64-apple-darwin11.4.2
Thread model: posix

and got rid of clang ports+system restart.

sudo port clean vxl
sudo port install vxl

aand... no luck, still crashing at the middle of vxl build... :( Should I rather open a new ticket for vxl? I attach here the log. Should I open a new ticket for vxl? I'll attach here the crash log.

Changed 8 years ago by bs1464@…

Attachment: main.2.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_vxl/vxl/main.log

comment:13 Changed 8 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

Yes, please open a separate ticket for vxl. The log you just attached seems to be incomplete and doesn't show any crash, BTW.

comment:14 in reply to:  13 Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to jmr@…:

Yes, please open a separate ticket for vxl.

The vxl ticket is #37547.

Note: See TracTickets for help on using tickets.