Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#37835 closed defect (duplicate)

pearl: add dependency on p5.12-lwp-useragent-determined

Reported by: cooljeanius (Eric Gallager) Owned by: rod@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch Cc: rod@…
Port: pearl

Description

When I first tried to use pearl after installing it, I got the following error:

Can't locate LWP/UserAgent.pm in @INC (@INC contains: /opt/local/lib/perl5/site_perl/5.12.4/darwin-thread-multi-2level /opt/local/lib/perl5/site_perl/5.12.4 /opt/local/lib/perl5/vendor_perl/5.12.4/darwin-thread-multi-2level /opt/local/lib/perl5/vendor_perl/5.12.4 /opt/local/lib/perl5/5.12.4/darwin-thread-multi-2level /opt/local/lib/perl5/5.12.4 /opt/local/lib/perl5/site_perl /opt/local/lib/perl5/vendor_perl .) at /opt/local/bin/pearl line 8.
BEGIN failed--compilation aborted at /opt/local/bin/pearl line 8.

So then I installed p5.12-lwp-useragent-determined and it worked.

Attachments (1)

Portfile.diff (583 bytes) - added by cooljeanius (Eric Gallager) 7 years ago.
diff to apply to Pearl's portfile

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by cooljeanius (Eric Gallager)

Attachment: Portfile.diff added

diff to apply to Pearl's portfile

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to rod@…

comment:2 Changed 7 years ago by cooljeanius (Eric Gallager)

Besides this patch, pearl could also have the macports category added to its categories (see #37832 for more on this). Also it's been 3 weeks, so maintainer timeout?

comment:3 Changed 7 years ago by rod@…

Changes added to Portfile...

https://github.com/rodnaph/pearl/commit/691c228e473a04e933ffff5c77a685ea1371614b

Will submit a port enhancement ticket soon.

Thanks!

comment:4 Changed 7 years ago by rod@…

Enhancement ticket raised:

https://trac.macports.org/ticket/38101

comment:5 in reply to:  4 Changed 7 years ago by cooljeanius (Eric Gallager)

Replying to rod@…:

Enhancement ticket raised:

https://trac.macports.org/ticket/38101

Thanks!

comment:6 Changed 7 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Let’s call this a duplicate of #38101.

comment:7 in reply to:  6 ; Changed 7 years ago by cooljeanius (Eric Gallager)

Replying to larryv@…:

Let’s call this a duplicate of #38101.

Duplicates can be in reverse chronological order? :-P

comment:8 in reply to:  7 Changed 7 years ago by larryv (Lawrence Velázquez)

Replying to egall@…:

Duplicates can be in reverse chronological order? :-P

happens all the time when you’re browsing Trac at RELATIVISTIC SPEEDS j/k I have DSL :(

Note: See TracTickets for help on using tickets.