Opened 4 years ago

Closed 2 years ago

#38906 closed defect (fixed)

Error: Processing of port keepassx failed

Reported by: gaga335@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: eborisch (Eric A. Borisch), technonerd@…, macports@…, martin.desruisseaux@…, martin.desruisseaux@…, dliessi (Davide Liessi)
Port: KeePassX

Description

Error: Processing of port keepassx failed

The problem seems zlib 1.2.x cannot be found in the path. Please let me know how to fix it. Many thanks!

--->  Computing dependencies for KeePassX
DEBUG: KeePassX has no conflicts
DEBUG: Searching for dependency: pkgconfig
DEBUG: Found Dependency: receipt exists for pkgconfig
DEBUG: Searching for dependency: cmake
DEBUG: Found Dependency: receipt exists for cmake
DEBUG: Searching for dependency: qt4-mac
DEBUG: Found Dependency: receipt exists for qt4-mac
DEBUG: Searching for dependency: libgcrypt
DEBUG: Found Dependency: receipt exists for libgcrypt
DEBUG: Executing org.macports.main (KeePassX)
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 501
DEBUG: euid changed to: 502
DEBUG: Skipping completed org.macports.archivefetch (KeePassX)
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: Skipping completed org.macports.fetch (KeePassX)
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: Skipping completed org.macports.checksum (KeePassX)
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: Skipping completed org.macports.extract (KeePassX)
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: Skipping completed org.macports.patch (KeePassX)
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: configure phase started at Wed Apr 24 17:39:59 CST 2013
--->  Configuring KeePassX
DEBUG: Using compiler 'Mac OS X clang'
DEBUG: Executing org.macports.configure (KeePassX)
DEBUG: Environment: CPATH='/opt/local/include' CFLAGS='-pipe -O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -O2 -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.8' PKG_CONFIG_PATH='/opt/local/lib/pkgconfig' CXX='/usr/bin/clang++' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_security_KeePassX/KeePassX/work/.CC_PRINT_OPTIONS' F90FLAGS='-pipe -O2 -m64' LDFLAGS='-L/opt/local/lib -arch x86_64' FCFLAGS='-pipe -O2 -m64' OBJC='/usr/bin/clang' INSTALL='/usr/bin/install -c' MOC='/opt/local/bin/moc' QMAKESPEC='macx-g++' FFLAGS='-pipe -O2 -m64' OBJCFLAGS='-pipe -O2 -arch x86_64' QTDIR='/opt/local' CC_PRINT_OPTIONS='YES' CC='/usr/bin/clang' QMAKE='/opt/local/bin/qmake'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_security_KeePassX/KeePassX/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/Applications/MacPorts -DQT_QT_INCLUDE_DIR=/opt/local/include  -DQT_QMAKESPEC=macx-g++  -DQT_ZLIB_LIBRARY=/opt/local/lib/libz.dylib  -DQT_PNG_LIBRARY=/opt/local/lib/libpng.dylib ../keepassx-2.0-alpha3'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_security_KeePassX/KeePassX/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/Applications/MacPorts -DQT_QT_INCLUDE_DIR=/opt/local/include  -DQT_QMAKESPEC=macx-g++  -DQT_ZLIB_LIBRARY=/opt/local/lib/libz.dylib  -DQT_PNG_LIBRARY=/opt/local/lib/libpng.dylib ../keepassx-2.0-alpha3 
CMake Error at CMakeLists.txt:179 (message):
  zlib 1.2.x or higher is required to use the gzip format


-- Configuring incomplete, errors occurred!
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_security_KeePassX/KeePassX/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/Applications/MacPorts -DQT_QT_INCLUDE_DIR=/opt/local/include  -DQT_QMAKESPEC=macx-g++  -DQT_ZLIB_LIBRARY=/opt/local/lib/libz.dylib  -DQT_PNG_LIBRARY=/opt/local/lib/libpng.dylib ../keepassx-2.0-alpha3 
Exit code: 1
Error: org.macports.configure for port KeePassX returned: configure failure: command execution failed
DEBUG: Error code: NONE
DEBUG: Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
Warning: targets not executed for KeePassX: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Please see the log file for port KeePassX for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_security_KeePassX/KeePassX/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port keepassx failed

Attachments (2)

main.log (32.9 KB) - added by technonerd@… 4 years ago.
CMakeError.log (9.9 KB) - added by dliessi (Davide Liessi) 2 years ago.
see comment:17

Download all attachments as: .zip

Change History (25)

comment:1 Changed 4 years ago by mf2k (Frank Schima)

  • Keywords keepassx removed
  • Port KeePassX added; keepassx removed

What is the output of the following?

port installed zlib

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

The output you showed above is not from a clean attempt. Please clean and try again and attach the main.log.

Changed 4 years ago by technonerd@…

comment:3 in reply to: ↑ description Changed 4 years ago by technonerd@…

Replying to gaga335@…:

I am running into the same problem, it looks like its building against the system zlib /usr/lib/libz.dylib and not /opt/local/lib/libz.dylib

-- Found ZLIB: /usr/lib/libz.dylib (found version "1.2.5")

$ port installed zlib

The following ports are currently installed:

zlib @1.2.7_0

zlib @1.2.8_0 (active)

comment:4 Changed 4 years ago by technonerd@…

  • Cc technonerd@… added

Cc Me!

comment:5 Changed 4 years ago by rememberthemer@…

The issue is that the KeePassX CMakeLists.txt runs a compilation test to determine if zlib version is > 1.2 has gzip support . The test is a snippet of c++ that includes zlib.h to check the version. The test has no means of setting the include path so the system copy (i.e. /usr/lib/zlib.h).

However it still should not fail. I have cut out the piece of code, compiled it as a stand-alone executable with all possible combos of clang, g++ and include paths etc. and it always works.

It doesn't look like an upstream bug, as the relevant code was committed in 2010 and there are no bug reports.

The immediate solution is to cut/patch out the test out of CMakeLists.txt as we know that zlib > 1.2.0

I've tried it and the build sails through ... until it chokes on a whole pile of clang cflags incompatibilities (this is an upstream bug).

I would suggest the port should be built with gcc4X.

comment:6 Changed 4 years ago by rememberthemer@…

  • Cc rememberthemer@… added

Cc Me!

comment:7 Changed 4 years ago by rememberthemer@…

  • Cc rememberthemer@… removed

Cc Me!

comment:8 Changed 4 years ago by macports@…

  • Cc macports@… added

Cc Me!

comment:9 Changed 4 years ago by eborisch (Eric A. Borisch)

  • Cc eborisch@… added
  • Resolution set to fixed
  • Status changed from new to closed

Hopefully fixed in r107426. Please reopen if it isn't.

comment:10 Changed 2 years ago by mf2k (Frank Schima)

  • Cc martin.desruisseaux@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Cc'ing reporter of duplicate #48628.

comment:11 Changed 2 years ago by martin.desruisseaux@…

Reproducing here the content of #48628: on the following configuration:

  • MacOS 10.7.5
  • XCode 4.6.3 (the latest one compatible with MacOS 10.7).
  • MacPort 2.3.3

Attempt to install KeePassX results in the following error. The full log is attached to #48628.

:info:configure -- Found ZLIB: /opt/local/lib/libz.dylib (found version "1.2.8") 
:info:configure -- Performing Test ZLIB_SUPPORTS_GZIP
:info:configure -- Performing Test ZLIB_SUPPORTS_GZIP - Failed
:info:configure CMake Error at CMakeLists.txt:187 (message):
:info:configure   zlib 1.2.x or higher is required to use the gzip format

port installed zlib gives me:

The following ports are currently installed:
  zlib @1.2.8_0 (active)

I also tried a drastic approach, with KeePassX as the very first port installed after cleaning everything:

port -f uninstall installed
port clean all
port selfupdate
port install KeePassX

I also tried explicit port install zlib without success.

comment:12 Changed 2 years ago by martin.desruisseaux@…

  • Cc martin.desruisseaux@… added

Cc Me!

comment:13 Changed 2 years ago by dliessi (Davide Liessi)

  • Cc davide.liessi@… added

Cc Me!

comment:14 Changed 2 years ago by dliessi (Davide Liessi)

Same error here, both with and without trace mode.

  • Mac OS 10.6.8
  • XCode 3.2.6
  • MacPorts 2.3.4

comment:15 Changed 2 years ago by dliessi (Davide Liessi)

With sudo port -t upgrade KeePassX configure.compiler=macports-gcc-4.9 it builds with no errors and seems to work fine.

comment:16 Changed 2 years ago by dliessi (Davide Liessi)

The same with configure.compiler=macports-gcc-4.7.

comment:17 follow-up: Changed 2 years ago by eborisch (Eric A. Borisch)

Glad to see you've found a work-around. I don't have a system with that OS; can you run:

sudo port clean keepassx && sudo port configure keepassx

and then attach the file located at `port dir keepassx`/work/build/CMakeFiles/CMakeError.log so we can try to identify the underlying issue?

Does building with configure.compiler=macports-clang-3.7 work?

Changed 2 years ago by dliessi (Davide Liessi)

comment:18 in reply to: ↑ 17 ; follow-up: Changed 2 years ago by dliessi (Davide Liessi)

Replying to eborisch@…:

and then attach the file located at `port dir keepassx`/work/build/CMakeFiles/CMakeError.log so we can try to identify the underlying issue?

Done.

Does building with configure.compiler=macports-clang-3.7 work?

I won't try with clang-3.7 since I don't have it installed and I don't want to spend several hours building it. I can try with clang-3.4 though.

comment:19 in reply to: ↑ 18 Changed 2 years ago by dliessi (Davide Liessi)

Replying to davide.liessi@…:

I can try with clang-3.4 though.

sudo port -t configure KeePassX configure.compiler=macports-clang-3.4 completed without errors.

comment:20 Changed 2 years ago by eborisch (Eric A. Borisch)

Try it now (as of r141016).

comment:21 follow-up: Changed 2 years ago by dliessi (Davide Liessi)

KeePassX built with no errors, but installed the .app bundle in /opt/local.

comment:22 in reply to: ↑ 21 Changed 2 years ago by dliessi (Davide Liessi)

but installed the .app bundle in /opt/local.

Patch ready at #49195.

comment:23 Changed 2 years ago by eborisch (Eric A. Borisch)

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing.

Note: See TracTickets for help on using tickets.