Opened 7 years ago

Closed 6 years ago

#41753 closed defect (duplicate)

libgcc-4.8.2_0+universal build fails on fresh reinstall of macports

Reported by: Polyergic (Shad Sterling) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: larryv (Lawrence Velázquez), cooljeanius (Eric Gallager)
Port: libgcc

Description (last modified by ryandesign (Ryan Schmidt))

To resolve a problem upgrading libgcc I saved my list of installed ports, removed everything, reinstalled macports, and tried installing libgcc from scratch. It still fails, apparently due to the same problem. In main.log there are a lot of messages that seem out of order, such as

   :info:build checking for inttypes.h... yes
   :info:build yes
   :info:build checking whether errno must be declared... checking for stdint.h... yes
   :info:build no
   :info:build checking for unsigned long long... checking size of int... yes
   :info:build checking for inttypes.h... 4
   :info:build checking for a 64-bit type... yes
   :info:build uint64_t

and

   :info:build configure: creating ./config.status
   :info:build -1
   :info:build checking for vfork.h... no

and there are an awful lot of compiler warnings, which I don't know enough to know if any are actually problematic. grep error main.log reveals the same error that occurred before the reinstall:

   :info:build configure: error: GNU Fortran is not working; please report a bug in http://gcc.gnu.org/bugzilla, attaching /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc48/libgcc/work/build/x86_64-apple-darwin11/libgfortran/config.log

From grep fatal config.log it looks like some of the source is missing:

   xgcc: fatal error: no input files
   xgcc: fatal error: no input files
   conftest.c:9:10: fatal error: 'ac_nonexistent.h' file not found
   conftest.c:52:26: fatal error: minix/config.h: No such file or directory
   conftest.c:19:10: fatal error: 'minix/config.h' file not found
   xgcc: fatal error: no input files
   xgcc: fatal error: no input files
   gfortran: fatal error: no input files
   gfortran: fatal error: no input files

I did the reinstall & rebuild more than once before I was sure I was getting the whole process right. I don't remember every variation, I started with the instructions at wiki:Migration and http://guide.macports.org/#installing.macports.uninstalling , and ended up with this:

   $ sudo port -qv installed > ~/Downloads/portslist.text
      # I figured out too late that I really only want requested ports e.g. port -qv installed requested
   $ sudo port -f uninstall installed
      # no errors
   $ sudo port clean all
      # no errors
   $ sudo rm -rf /opt/local /Applications/DarwinPorts /Applications/MacPorts /Library/LaunchDaemons/org.macports.* /Library/Receipts/DarwinPorts*.pkg /Library/Receipts/MacPorts*.pkg /Library/StartupItems/DarwinPortsStartup /Library/Tcl/darwinports1.0 /Library/Tcl/macports1.0 ~/.macports
      # not all existed
   $ /System/Library/CoreServices/Installer.app/Contents/MacOS/Installer ~/Downloads/MacPorts-2.2.1-10.7-Lion.pkg
      # GUI install succeded
   $ sudo less /opt/local/etc/macports/macports.conf
      # all at defaults
   $ sudo port selfupdate
      # ports tree updated
   $ sudo port upgrade outdated
      # nothing to do
   $ sudo port upgrade installed
      # nothing to do
   $ sudo port install libgcc +universal
      # succeeds on all prerequisites, fails on libgcc; see attached log
   $ 

Running OS X 10.7.5 with XCode 4.6.3 (4H1503) on a mid-2008 macbook (too old for 10.9 so I can't upgrade XCode, it doesn't look like 10.8 is still available). The computer slept at some point during the build, which I hope has no effect on the process.

Attachments (4)

main.log (18.9 MB) - added by Polyergic (Shad Sterling) 7 years ago.
main.log
config.log (80.8 KB) - added by Polyergic (Shad Sterling) 7 years ago.
config.log
main.2.log (16.2 MB) - added by mihaela.sighireanu@… 7 years ago.
config.2.log (80.7 KB) - added by mihaela.sighireanu@… 7 years ago.

Change History (11)

Changed 7 years ago by Polyergic (Shad Sterling)

Attachment: main.log added

main.log

Changed 7 years ago by Polyergic (Shad Sterling)

Attachment: config.log added

config.log

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to mww@…

Changed 7 years ago by mihaela.sighireanu@…

Attachment: main.2.log added

Changed 7 years ago by mihaela.sighireanu@…

Attachment: config.2.log added

comment:2 Changed 7 years ago by mihaela.sighireanu@…

I obtained the same behaviour after reinstalling MacPorts on my Mac OS X 1.6 with XCode 3.2 and provided gcc4.2.

comment:3 Changed 7 years ago by Polyergic (Shad Sterling)

#40439 may be related; it was never fixed but closed as invalid after the affected system was lost to an HD failure.

My old MacBook has also failed, but with the the HD still working. After moving the HD to a new MacBook, upgrading to Mavericks, reinstalling XCode and MacPorts, and running $(port selfupdate; port upgrade outdated), libgcc-4.8.2_0+universal is now installed.

I don't think this bug is fixed, but I am no longer affected by it.

comment:4 Changed 7 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:5 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:6 Changed 7 years ago by cooljeanius (Eric Gallager)

This is the actual error from the log:

:info:build configure: error: GNU Fortran is not working; please report a bug in http://gcc.gnu.org/bugzilla, attaching /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc48/libgcc/work/build/x86_64-apple-darwin10/libgfortran/config.log
:info:build config.status: executing default-1 commands
:info:build make[1]: *** [configure-target-libgfortran] Error 1
:info:build make[1]: *** Waiting for unfinished jobs....

In which case that means that this is a duplicate of #40548, which means that is actually an issue with mpfr (#42732) and/or libmpc (#42733) that would have been caught if their testsuites had been run automatically (#42731)

comment:7 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #40548.

Note: See TracTickets for help on using tickets.