Opened 7 years ago

Closed 7 years ago

#41882 closed defect (duplicate)

openjpeg @2.0.0_1+universal: multiple "undeclared identifier" build errors

Reported by: dllau@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: openjpeg

Description


Attachments (1)

main.log (141.8 KB) - added by dllau@… 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by dllau@…

Attachment: main.log added

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to mcalhoun@…
Port: openjpeg added
Summary: openjpegopenjpeg @2.0.0_1+universal: multiple "undeclared identifier" build errors

Thanks for the ticket. In the future, please Cc relevant port maintainers (e.g., port info --maintainers openjpeg).

comment:2 Changed 7 years ago by gnw3

This occurs if you have openjpeg15 installed. This port provides a "/opt/local/include/openjpeg.h" that conflicts with openjpeg ver 2. A workaround is to temporarily rename "/opt/local/include/openjpeg.h" while installing/updating openjpeg ver. 2.

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #41216.

Note: See TracTickets for help on using tickets.