Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#42769 closed defect (duplicate)

autoopts-config --libs produces incorrect results (breaks gnutls build)

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port: autogen gnutls

Description

$ autoopts-config --libs
 -R -L/opt/local/lib -lopts

Which causes gnutls to fail to build:

/bin/sh ../libtool  --tag=CC   --mode=link /usr/bin/clang   -pipe -Os -arch x86_64  -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64 -o gnutls-cli cli.o common.o socket.o ocsptool-common.o benchmark-cipher.o benchmark.o benchmark-tls.o ../lib/libgnutls.la  libcmd-cli.la ../gl/libgnu.la -R -L/opt/local/lib -lopts -L/opt/local/lib -lintl -R/opt/local/lib -Wl,-framework -Wl,CoreFoundation     -lintl 
libtool: link: only absolute run-paths are allowed

Change History (2)

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Duplicate of #42728.

comment:2 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.