Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#42889 closed enhancement (fixed)

gnuplot variant for qalculate-gtk

Reported by: jjstickel (Jonathan Stickel) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: maintainer haspatch Cc: mojca (Mojca Miklavec)
Port: qalculate-gtk

Description

The attached patch for qalculate-gtk adds a gnuplot variant and makes some other small changes: corrected email for maintainer, adjusted checksums, and adjusted gtk2 dependency. Regarding the last point, I am successfully running qalculate-gtk with gtk2+qartz, i.e. no X11.

Attachments (2)

qalculate-gtk_Portfile.diff (1.4 KB) - added by jjstickel (Jonathan Stickel) 7 years ago.
main.log (144.1 KB) - added by mf2k (Frank Schima) 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by jjstickel (Jonathan Stickel)

Attachment: qalculate-gtk_Portfile.diff added

comment:1 Changed 7 years ago by mf2k (Frank Schima)

I get an error when i try to build this on 10.9.2 Xcode 5.1.

:info:build                                                                                                                                                                                      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:info:build ./support.h:25:21: note: expanded from macro '_'
:info:build #  define _(String) dgettext (PACKAGE, String)
:info:build                     ^~~~~~~~~~~~~~~~~~~~~~~~~~
:info:build callbacks.cc:12498:38: warning: format specifies type 'int' but the argument has type 'unsigned long' [-Wformat]
:info:build                                         pos_str = g_strdup_printf("%i", i_column + 1 + matrix_edit_columns.size() * gtk_tree_path_get_indices(path)[0]);
:info:build                                                                    ~~   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:info:build                                                                    %lu
:info:build callbacks.cc:12662:38: warning: format specifies type 'int' but the argument has type 'unsigned long' [-Wformat]
:info:build                                         pos_str = g_strdup_printf("%i", i_column + 1 + matrix_columns.size() * gtk_tree_path_get_indices(path)[0]);
:info:build                                                                    ~~   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:info:build                                                                    %lu
:info:build In file included from callbacks.cc:30:
:info:build In file included from ./callbacks.h:24:
:info:build In file included from ./main.h:33:
:info:build In file included from /opt/local/include/libqalculate/qalculate.h:15:
:info:build In file included from /opt/local/include/libqalculate/includes.h:21:
:info:build In file included from /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/../lib/c++/v1/vector:265:
:info:build In file included from /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/../lib/c++/v1/__bit_reference:15:
:info:build /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/../lib/c++/v1/algorithm:685:97: error: invalid operands to binary expression ('const tree_struct' and 'const tree_struct')
:info:build     _LIBCPP_INLINE_VISIBILITY bool operator()(const _T1& __x, const _T1& __y) const {return __x < __y;}
:info:build                                                                                             ~~~ ^ ~~~

Changed 7 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:2 Changed 7 years ago by jjstickel (Jonathan Stickel)

I am still on 10.8.5 and Xcode 4.6.2.

Does the existing qalculate-gtk port compile in 10.9.X? If not, then it is a separate issue not related to these changes (but a bug that needs fixing nonetheless).

comment:3 Changed 7 years ago by mf2k (Frank Schima)

You should really update to Xcode 5.1 then - it is available (and preferred) on 10.8. You will see the same issues as I would because the clang version is the same.

comment:4 in reply to:  3 Changed 7 years ago by jjstickel (Jonathan Stickel)

Replying to macsforever2000@…:

You should really update to Xcode 5.1 then - it is available (and preferred) on 10.8. You will see the same issues as I would because the clang version is the same.

I installed Xcode 5.1 and command-line tools. Qalculate-gtk builds fine for me. I rebuilt gtk2+quartz to see if there might be some problem linking to gtk2 that was previously built with Xcode 4.6, but still all OK. I would rather not blindly rebuild all the deps, and from what I can tell, it looks like the error you see is directly from the qalculate-gtk sources.

comment:5 Changed 7 years ago by mf2k (Frank Schima)

FYI:

$ port installed gtk2
The following ports are currently installed:
  gtk2 @2.24.23_0+x11 (active)

Is it that I have the x11 variant installed for gtk2?

comment:6 in reply to:  5 Changed 7 years ago by jjstickel (Jonathan Stickel)

Replying to macsforever2000@…:

Is it that I have the x11 variant installed for gtk2?

On another machine, also 10.8.5 with Xcode 5.1 (where I was willing to install all the x11 dependencies), I tried with gtk2+x11, and again it works fine. So I cannot reproduce this error.

comment:7 Changed 7 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added
Version: 2.2.1

Given that the port doesn't even change the sources, but only adds a variant, changes the email, adds checksums ... why not simply committing the patch and open a new ticket for the problems related to Xcode 5.1?

comment:8 in reply to:  7 ; Changed 7 years ago by jjstickel (Jonathan Stickel)

Replying to mojca@…:

Given that the port doesn't even change the sources, but only adds a variant, changes the email, adds checksums ... why not simply committing the patch and open a new ticket for the problems related to Xcode 5.1?

This makes sense to me. If you commit this patch and close this ticket, I will take the time to open another ticket to report the problem raised by macsforever2000.

comment:9 in reply to:  8 ; Changed 7 years ago by mf2k (Frank Schima)

Replying to jjstickel@…:

This makes sense to me. If you commit this patch and close this ticket, I will take the time to open another ticket to report the problem raised by macsforever2000.

My personal policy is to not commit any changes that don't build for me. Any other committer is free to commit this of course. I also do not have very much free time.

Can you please verify that you fully uninstalled Xcode 4.6 from your computer? Namely that you ran:

sudo /Developer/Library/uninstall-devtools --mode=all

comment:10 in reply to:  9 Changed 7 years ago by jjstickel (Jonathan Stickel)

Replying to macsforever2000@…:

Can you please verify that you fully uninstalled Xcode 4.6 from your computer? Namely that you ran:

sudo /Developer/Library/uninstall-devtools --mode=all

I did not run this, and I do not have a /Developer folder (at least not now). Also:

$ /usr/bin/clang --version
Apple LLVM version 5.1 (clang-503.0.38) (based on LLVM 3.4svn)
Target: x86_64-apple-darwin12.5.0
Thread model: posix

So it seems my Apple clang corresponds to Xcode 5.1. BTW, the bug appears to be related to #42866 which did reproduce on my machine. I do find it strange that I don't experience the build problem with qalculate-gtk.

comment:11 Changed 7 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed

I committed r118419. I consider all these cosmetic changes only – those problems you experience are already present now. Please open a new ticket with build problems.

(I'm sorry, I forgot to reference the ticket number in the commit message, but now it's too late.)

Note: See TracTickets for help on using tickets.