Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#43097 closed defect (duplicate)

arm-elf-gdb: error: non-void function 'ARMul_MRC' should return a value

Reported by: irony42@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: billy@…
Port: arm-elf-gdb

Description (last modified by ryandesign (Ryan Schmidt))

The problem is:

... /work/gdb-7.1/sim/arm/armsupp.c:639:7: error: non-void function 'ARMul_MRC' should return a value [-Wreturn-type]

The port builds fine once this is corrected (either by changing the offending line or by disabling -Wreturn-type).

Change History (2)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Resolution: duplicate
Status: newclosed
Summary: arm-elf-gdb fails to buildarm-elf-gdb: error: non-void function 'ARMul_MRC' should return a value

Duplicate of #39916.

comment:2 Changed 6 years ago by irony42@…

...and duped to myself :|

Note: See TracTickets for help on using tickets.