Opened 8 years ago

Closed 8 years ago

#43282 closed defect (invalid)

gmp fails to build

Reported by: MaurizioLoreti Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: jweede@…, nerdling (Jeremy Lavergne)
Port: gmp

Description

I have two computers running OS X 10.9.2, a macbook and an imac. While on the macbook gmp-6.0.0a has been upgraded correctly, on the imac I get errors. In the log file is reported several times an error like

error: couldn't create cache file '/var/folders/1x/1dr7qt7n2rn1zbvly71c3vx40000gv/T/...name...

so I have tried to manually sudo chmod 755 /var/folders/1x/1dr7qt7n2rn1zbvly71c3vx40000gv/T/ without changes. The commands to upgrade are

MLO@bigmac 16 $ sudo port clean gmp
--->  Cleaning gmp
MLO@bigmac 17 $ sudo port upgrade gmp
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports.
--->  Fetching distfiles for gmp
--->  Verifying checksums for gmp
--->  Extracting gmp
--->  Configuring gmp
--->  Building gmp
Error: org.macports.build for port gmp returned: command execution failed
Please see the log file for port gmp for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
MLO@bigmac 18 $ 

The logfile (compressed) is in the attachment.

Attachments (1)

main.log.gz (40.3 KB) - added by MaurizioLoreti 8 years ago.
log file

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by MaurizioLoreti

Attachment: main.log.gz added

log file

comment:1 Changed 8 years ago by MaurizioLoreti

Cc: Maurizio.Loreti@… added

Cc Me!

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: mcalhoun@… Maurizio.Loreti@… removed
Keywords: gmp removed
Owner: changed from macports-tickets@… to mcalhoun@…

Are you able to use xcrun manually, outside of MacPorts? This does not sound like a gmp- or MacPorts-specific problem; it sounds like your permissions, somewhere, are wront.

comment:3 in reply to:  2 Changed 8 years ago by MaurizioLoreti

Replying to ryandesign@…:

Are you able to use xcrun manually, outside of MacPorts? This does not sound like a gmp- or MacPorts-specific problem; it sounds like your permissions, somewhere, are wront.

Oh, I forgot - having read in the log file that errors were related to file permissions, I ran Disk Utility in order to repair them. Nothing changed, I got the same error. What do you mean by "manually using xcrun"?

comment:4 Changed 8 years ago by bmhatfield@…

I'd like to note that I'm also having this problem. I'm not installing gmp or running anything outside of macports manually; it's being brought in as a dependency.

:info:build clang: error: couldn't create cache file '/var/folders/s9/04wtzlb97xv9zvq6f6qg68j80000gq/T/xcrun_db-gQNIwNSa' (errno=Permission denied)
:info:build ld: illegal text-relocation to '___gmp_binvert_limb_table' in .libs/mp_minv_tab.o from '___gmpn_divexact_1' in mpn/.libs/dive_1.o for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[2]: *** [libgmp.la] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.0.0'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.0.0'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.0.0'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/work/gmp-6.0.0" && /usr/bin/make -j4 -w all
:info:build Exit code: 2
:error:build org.macports.build for port gmp returned: command execution failed
:debug:build Error code: CHILDSTATUS 26278 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for gmp: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port gmp for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_gmp/gmp/main.log

comment:5 Changed 8 years ago by bmhatfield@…

I'd like to additionally add that this issue is blocking the ability to rebuild openssl + dependencies w/r/t heartbleed.

comment:6 Changed 8 years ago by jweede@…

Cc: jweede@… added

Cc Me!

comment:7 Changed 8 years ago by jweede@…

The xcrun message looks like a redherring: it occurs many times.

The linker failure (illegal text-relocation) is likely the real error.

comment:8 Changed 8 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added

Cc Me!

comment:9 Changed 8 years ago by neverpanic (Clemens Lang)

Try sudo rm -rf /var/folders/1x/1dr7qt7n2rn1zbvly71c3vx40000gv, clean the port and try again. I've seen this a couple of times, but I'm not sure why it happens. The files are only caches, though, so deleting them isn't a problem -- they'll be re-created anyway.

comment:10 in reply to:  9 Changed 8 years ago by nerdling (Jeremy Lavergne)

Replying to cal@…:

Try sudo rm -rf /var/folders/1x/1dr7qt7n2rn1zbvly71c3vx40000gv, clean the port and try again.

Confirmed: this is fixed by removing the tmp dir and cleaning leads to a successful install.

comment:11 Changed 8 years ago by jweede@…

Issue resolved. Thanks!

comment:12 in reply to:  9 Changed 8 years ago by MaurizioLoreti

Replying to cal@…:

Try sudo rm -rf /var/folders/1x/1dr7qt7n2rn1zbvly71c3vx40000gv, clean the port and try again. I've seen this a couple of times, but I'm not sure why it happens. The files are only caches, though, so deleting them isn't a problem -- they'll be re-created anyway.

Well, now gmp upgrades correctly to the last version. Thank you for the fix...

comment:13 Changed 8 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: invalid
Status: newclosed

Closing ticket since this doesn't seem to be a MacPorts-related issue and a workaround was provided.

Note: See TracTickets for help on using tickets.