Opened 7 years ago

Closed 7 years ago

#43547 closed defect (invalid)

py27-matplotlib Instalation fails

Reported by: unai.herran@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: seanfarley (Sean Farley)
Port: py27-matplotlib

Description (last modified by ryandesign (Ryan Schmidt))

While doing the instalation of py27-matplot I receive the following error.

--->  Computing dependencies for py27-matplotlib
--->  Building py27-matplotlib
Error: org.macports.build for port py27-matplotlib returned: command execution failed
Please see the log file for port py27-matplotlib for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-matplotlib/py27-matplotlib/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port py27-matplotlib failed
Macintosh:~ unaiherran1$ sudo port install py27-matplotlib
--->  Computing dependencies for py27-matplotlib
--->  Building py27-matplotlib
Error: org.macports.build for port py27-matplotlib returned: command execution failed
Please see the log file for port py27-matplotlib for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-matplotlib/py27-matplotlib/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port py27-matplotlib failed

not sure if its a bug or was just caused by a failed installation attempt

Attachments (1)

main.log (74.5 KB) - added by unai.herran@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by unai.herran@…

Attachment: main.log added

comment:2 Changed 7 years ago by unai.herran@…

It seems that the only thing needed to do was to :

sudo port  clean py27-matplot

and then

sudo port install py27-matplot
Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 in reply to:  2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: sean@… added
Description: modified (diff)
Port: py27-matplotlib added
Resolution: invalid
Status: newclosed

Replying to unai.herran@…:

It seems that the only thing needed to do was to :

sudo port  clean py27-matplot

and then

sudo port install py27-matplot

Right, cleaning and trying again is the first prerequisite before filing a ticket. Also, remember to use WikiFormatting when writing in Trac, fill in the Port field, and Cc the maintainer of the port.

Note: See TracTickets for help on using tickets.