Opened 7 years ago

Closed 7 years ago

#44057 closed defect (fixed)

BGHUDAppKit @0.7: error: garbage collection is no longer supported

Reported by: jgmath2000@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: Cc: rudloff@…, AP1010, springermac (Jonathan Springer), an0nym@…, Dmole (Tim)
Port: BGHUDAppKit

Description

Attached is the log from a clean build attempt

Attachments (3)

main.log (87.5 KB) - added by jgmath2000@… 7 years ago.
Build Log.
main.2.log (6.9 KB) - added by wintermute_77@… 7 years ago.
main.log -- with patch applied
iosfail.7z (5.1 KB) - added by Dmole (Tim) 7 years ago.

Download all attachments as: .zip

Change History (24)

Changed 7 years ago by jgmath2000@…

Attachment: main.log added

Build Log.

comment:1 Changed 7 years ago by jgmath2000@…

I think this line is the problem:

    :info:build error: garbage collection is no longer supported

comment:2 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jeremyhu@…

In the future, please Cc the port maintainers (port info --maintainers BGHUDAppKit).

comment:3 Changed 7 years ago by rudloff@…

Cc: rudloff@… added

Cc Me!

comment:4 Changed 7 years ago by AP1010

Cc: arthur@… added

Cc Me!

comment:5 Changed 7 years ago by springermac (Jonathan Springer)

Cc: springermac@… added

Cc Me!

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Summary: BGHUDAppKit fails to build with latest xcodeBGHUDAppKit @0.7: error: garbage collection is no longer supported

Duplicate #44378 purports to provide a fix.

comment:7 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yeah, that patch looks good to me. Anyone interested, feel free to commit that, or I will when I get back from vacation.

comment:8 in reply to:  7 Changed 7 years ago by wintermute_77@…

Replying to jeremyhu@…:

Yeah, that patch looks good to me. Anyone interested, feel free to commit that, or I will when I get back from vacation.

Received the following error when applying the patch. (attached)

Changed 7 years ago by wintermute_77@…

Attachment: main.2.log added

main.log -- with patch applied

comment:9 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

:info:build 2014-10-18 11:03:00.723 xcodebuild[82632:1171047] [MT] iPhoneSimulator: SimVerifier returned: Error Domain=NSPOSIXErrorDomain Code=53 "Simulator verification failed." UserInfo=0x7fa951c335a0 {NSLocalizedFailureReason=A connection to the simulator verification service could not be established., NSLocalizedRecoverySuggestion=Ensure that Xcode.app is installed on a volume with ownership enabled., NSLocalizedDescription=Simulator verification failed.}

This has nothing to do with the patch being correct or not. There was a problem running xcodebuild, and it aborted. For some reason, xcodebuild could not connect to the simulator verification service to fixup the iOS Simulator. Can you please attach /var/log/system.log and ~/Library/Logs/CoreSimualtor/*.log contents from around the time of the failure (or email them to me if you don't want to attach that data)

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:10 Changed 7 years ago by wintermute_77@…

I believe that something in xcode wasn't initialized after installation. After running xcode, which ran some sort of registration process for 10-20 minutes, the patch, as submitted, worked. I can fetch those logs if you'd like, but I imagine they don't contain any relevant information for you. Thanks.

comment:11 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

They certainly do contain relevant information for me (although not for this ticket or MacPorts in general) as I maintain the code that is reporting that failure. I want to understand why you hit that error.

comment:12 Changed 7 years ago by an0nym@…

Cc: an0nym@… added

Cc Me!

comment:13 in reply to:  9 ; Changed 7 years ago by Dmole (Tim)

Replying to jeremyhu@…:

...logs...

 ls -1 ~/Library/Logs/CoreSimualtor/
ls: /Users/user/Library/Logs/CoreSimualtor/: No such file or directory

starting the simulator from xcode results in a black screen (not the normal UI)

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 7 years ago by Dmole (Tim)

Attachment: iosfail.7z added

comment:14 Changed 7 years ago by Dmole (Tim)

Cc: elatllat@… added

Cc Me!

comment:15 Changed 7 years ago by Dmole (Tim)

see #45445

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:16 in reply to:  13 Changed 7 years ago by Dmole (Tim)

Replying to elatllat@…:

Replying to jeremyhu@…:

...logs...

 ls -1 ~/Library/Logs/CoreSimualtor/
ls: /Users/user/Library/Logs/CoreSimualtor/: No such file or directory

starting the simulator from xcode results in a black screen (not the normal UI)

Ah you made a typo and I missed it the first time; it's: ~/Library/Logs/CoreSimulator/*.log

Anyway running the simulator once fixed the issue (took a long time though)

comment:17 in reply to:  description Changed 7 years ago by tobefrank.yys@…

Replying to jgmath2000@…:

Attached is the log from a clean build attempt

I just solved this question by myself one minute ago. I think the main problem of you might just update command line tool version and Xcode version, followed by update macport and immigration your package from myreport.txt. If this is the case, please firstly spotlight your 'disk utility' and then click 'inf' on the header to see your Owners Enabled. If it shows Yes, then the main reason to failed installation is you forgot to run Xcode after upgrade at least once. Despite your version could be confirmed from the terminal directly, it still need to run at lease once to verify the initial setting. After that, you should install whatever you want from macport

comment:18 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

No, there is an underlying problem connecting to the verification setvice, and I would really like to see the requested logs for anyone experiencing the issue (before they fix it by running xcode)

comment:19 in reply to:  18 Changed 7 years ago by Dmole (Tim)

Replying to jeremyhu@…:

No, there is an underlying problem connecting to the verification setvice, and I would really like to see the requested logs for anyone experiencing the issue (before they fix it by running xcode)

I gave you system.log (in iosfail.7z​), and there is nothing related in ~/Library/Logs/CoreSimulator/*.log. I'm sure you can verify this with a fresh install.

comment:20 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Ok, it looks like the sim verifier is just one of many failing connections, so it's not sim specific. It would be great if you would file a radar for your issue at http://bugreport.apple.com as well, thanks.

comment:21 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.