Opened 7 years ago

Closed 7 years ago

#45422 closed defect (duplicate)

cmake fails to configure under Yosemite

Reported by: easye Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc: cssdev
Port: cmake

Description

Error

-- The CXX compiler identification is AppleClang 6.0.0.6000051
CMake Warning at Modules/Platform/Darwin.cmake:179 (message):
  Ignoring CMAKE_OSX_SYSROOT value:

   /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk

  because the directory does not exist.
Call Stack (most recent call first):
  Modules/CMakeSystemSpecificInformation.cmake:36 (include)
  CMakeLists.txt:16 (project)


CMake Error at Modules/Platform/Darwin.cmake:213 (message):
  CMAKE_OSX_DEPLOYMENT_TARGET is '10.10' but CMAKE_OSX_SYSROOT:

   ""

  is not set to a MacOSX SDK with a recognized version.  Either set
  CMAKE_OSX_SYSROOT to a valid SDK or set CMAKE_OSX_DEPLOYMENT_TARGET to
  empty.
Call Stack (most recent call first):
  Modules/CMakeSystemSpecificInformation.cmake:36 (include)
  CMakeLists.txt:16 (project)


-- Configuring incomplete, errors occurred!

Attachments (1)

main.log (25.0 KB) - added by easye 7 years ago.
cmake error log

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by easye

Attachment: main.log added

cmake error log

comment:1 Changed 7 years ago by easye

Cc: easieste@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: easieste@… removed
Milestone: MacPorts 2.3.2
Resolution: duplicate
Status: newclosed

Duplicate of #44581.

Note: See TracTickets for help on using tickets.