Opened 3 years ago

Last modified 3 years ago

#45423 new enhancement

glances: unecessarily forces python 3.4 when 2.7 should work

Reported by: vergus@… Owned by: g5pw (Aljaž Srebrnič)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc:
Port: glances

Description (last modified by ryandesign (Ryan Schmidt))

glances claims to work with python >= 2.6 so the default python version for this port should be 2.7. The comment when this was changed from 2.7 to 3.4 just says "use latest python", so it sounds more like the maintainer's preference rather than a requirement.

Change History (4)

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Owner changed from macports-tickets@… to g5pw@…
  • Type changed from defect to enhancement

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)

comment:3 Changed 3 years ago by g5pw (Aljaž Srebrnič)

Yes, I don't use python2, so it's easier for me to maintain it for python3. As always, patches welcome.

Last edited 3 years ago by g5pw (Aljaž Srebrnič) (previous) (diff)

comment:4 Changed 3 years ago by mf2k (Frank Schima)

Ultimately python 2.7 is still the default python for Macports and thus this port should support it by default.

Note: See TracTickets for help on using tickets.