Opened 7 years ago

Closed 6 years ago

#45475 closed defect (invalid)

osxfuse gets lost lost

Reported by: Dmole (Tim) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: osxfuse

Description

:info:build error: Unable to create directory: /Users/Shared/xCode/osxfusefs.build/Release/osxfusefs.build (Operation not permitted)

Attachments (4)

main.log (37.6 KB) - added by Dmole (Tim) 7 years ago.
manual.log (257.2 KB) - added by Dmole (Tim) 7 years ago.
build_debug.log (1.7 KB) - added by Dmole (Tim) 7 years ago.
build_debug_m.log (1.4 KB) - added by Dmole (Tim) 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by Dmole (Tim)

Attachment: main.log added

comment:1 Changed 7 years ago by Dmole (Tim)

also

find / -iname osxfusefs.build 2>/dev/null

found nothing.

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to dports@…

comment:3 Changed 7 years ago by Dmole (Tim)

manually running build.sh seems to work but I'm not sure where to go from there.

Changed 7 years ago by Dmole (Tim)

Attachment: manual.log added

comment:4 Changed 7 years ago by Dmole (Tim)

At line 1912 of build.sh, printenv is the only thing I thought of checking that differs.

Changed 7 years ago by Dmole (Tim)

Attachment: build_debug.log added

Changed 7 years ago by Dmole (Tim)

Attachment: build_debug_m.log added

comment:5 Changed 7 years ago by ryandesign (Ryan Schmidt)

Does the directory /Users/Shared/xCode exist? MacPorts shouldn't care about anything in /Users/Shared, I'm just wondering if this is a path the developer used on his system (I can't find any occurrences in the tarball) or if this is a directory you already had on your system which the build is noticing for some reason. If the latter, try moving it out of the way before building this port.

comment:6 in reply to:  5 Changed 7 years ago by Dmole (Tim)

Replying to ryandesign@…:

Does the directory /Users/Shared/xCode exist?

Yes it's the xCode project folder. Removing the folder and doing a clean build results in the same issue.

Maybe xcodebuild is assuming the default folder because none is provided on the command line.

comment:7 Changed 7 years ago by Dmole (Tim)

I tried

mkdir -p /Users/Shared/xCode/osxfusefs.build/Release/osxfusefs.build
chmod -R 0777 /Users/Shared/xCode/osxfusefs.build/

but port would not have it

:info:build error: Unable to write to file /Users/Shared/xCode/osxfusefs.build/Release/osxfusefs.build/osxfusefs-all-target-headers.hmap (You don’t have permission to save the file “osxfusefs-all-target-headers.hmap” in the folder “osxfusefs.build”.)

comment:8 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: invalid
Status: newclosed

I can't reproduce this. osxfuse installs fine for me on Yosemite. Nobody else has reported this problem so I'm going to close this as not a MacPorts bug. It must be something peculiar about your system; I'm sorry I don't know how to help you debug it further.

/Users/Shared/xCode is not a standard directory, based on the fact that "xCode" is not how "Xcode" is properly capitalized and that there are only 7 hits for the Google search "/users/shared/xcode", one of which is this ticket.

osxfuse and Xcode have both been updated several times since you filed your ticket; maybe if you update Xcode and try again with an up to date MacPorts (sudo port selfupdate), it'll work for you too.

Note: See TracTickets for help on using tickets.