Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#45519 closed defect (duplicate)

Issue building cmake on OSX 10.10

Reported by: tim.lock@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc:
Port: cmake

Description

port upgrade outdated

---> Computing dependencies for cmake ---> Configuring cmake Error: org.macports.configure for port cmake returned: configure failure: command execution failed Please see the log file for port cmake for details:

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/main.log

Error: Problem while installing cmake

--

g++ -framework CoreFoundation -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/Bootstrap.cmk -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/Source -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/Bootstrap.cmk cmStandardIncludes.o cmake.o cmakemain.o cmcmd.o cmCommandArgumentLexer.o cmCommandArgumentParser.o cmCommandArgumentParserHelper.o cmDefinitions.o cmDepends.o cmDependsC.o cmDocumentationFormatter.o cmPolicies.o cmProperty.o cmPropertyMap.o cmPropertyDefinition.o cmPropertyDefinitionMap.o cmMakeDepend.o cmMakefile.o cmExportFileGenerator.o cmExportInstallFileGenerator.o cmExportTryCompileFileGenerator.o cmExportSet.o cmExportSetMap.o cmInstallDirectoryGenerator.o cmGeneratedFileStream.o cmGeneratorTarget.o cmGeneratorExpressionDAGChecker.o cmGeneratorExpressionEvaluator.o cmGeneratorExpressionLexer.o cmGeneratorExpressionParser.o cmGeneratorExpression.o cmGlobalGenerator.o cmLocalGenerator.o cmInstallGenerator.o cmInstallExportGenerator.o cmInstallFilesGenerator.o cmInstallScriptGenerator.o cmInstallTargetGenerator.o cmScriptGenerator.o cmSourceFile.o cmSourceFileLocation.o cmSystemTools.o cmTestGenerator.o cmVersion.o cmFileTimeComparison.o cmGlobalUnixMakefileGenerator3.o cmLocalUnixMakefileGenerator3.o cmMakefileExecutableTargetGenerator.o cmMakefileLibraryTargetGenerator.o cmMakefileTargetGenerator.o cmMakefileUtilityTargetGenerator.o cmOSXBundleGenerator.o cmNewLineStyle.o cmBootstrapCommands1.o cmBootstrapCommands2.o cmCommandsForBootstrap.o cmTarget.o cmTest.o cmCustomCommand.o cmCustomCommandGenerator.o cmCacheManager.o cmListFileCache.o cmComputeLinkDepends.o cmComputeLinkInformation.o cmOrderDirectories.o cmComputeTargetDepends.o cmComputeComponentGraph.o cmExprLexer.o cmExprParser.o cmExprParserHelper.o cmGlobalNinjaGenerator.o cmLocalNinjaGenerator.o cmNinjaTargetGenerator.o cmNinjaNormalTargetGenerator.o cmNinjaUtilityTargetGenerator.o cmListFileLexer.o Directory.o EncodingCXX.o Glob.o RegularExpression.o SystemTools.o EncodingC.o ProcessUNIX.o String.o System.o -o cmake loading initial cache file /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/Bootstrap.cmk/InitialCacheFlags.cmake -- The C compiler identification is AppleClang 6.0.0.6000051 -- The CXX compiler identification is AppleClang 6.0.0.6000051 CMake Warning at Modules/Platform/Darwin.cmake:179 (message):

Ignoring CMAKE_OSX_SYSROOT value:

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk

because the directory does not exist.

Call Stack (most recent call first):

Modules/CMakeSystemSpecificInformation.cmake:36 (include) CMakeLists.txt:16 (project)

CMake Error at Modules/Platform/Darwin.cmake:213 (message):

CMAKE_OSX_DEPLOYMENT_TARGET is '10.10' but CMAKE_OSX_SYSROOT:

""

is not set to a MacOSX SDK with a recognized version. Either set CMAKE_OSX_SYSROOT to a valid SDK or set CMAKE_OSX_DEPLOYMENT_TARGET to empty.

Call Stack (most recent call first):

Modules/CMakeSystemSpecificInformation.cmake:36 (include) CMakeLists.txt:16 (project)

-- Configuring incomplete, errors occurred! See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/CMakeFiles/CMakeOutput.log".


Error when bootstrapping CMake: Problem while running initial CMake

Change History (2)

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Duplicate of #44581. Download Xcode 6.1 and try installing again.

comment:2 Changed 7 years ago by jmroot (Joshua Root)

Milestone: MacPorts 2.3.2
Note: See TracTickets for help on using tickets.