Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#45711 closed defect (fixed)

libxml2-2.9.2_0 links shared libs with -flat_namespace on Yosemite

Reported by: jhowarth@… Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc:
Port: libxml2

Description (last modified by larryv (Lawrence Velázquez))

% otool -hv /opt/local/lib/libxml2.2.dylib
/opt/local/lib/libxml2.2.dylib:
Mach header
      magic cputype cpusubtype  caps    filetype ncmds sizeofcmds      flags
MH_MAGIC_64  X86_64        ALL  0x00       DYLIB    17       1872 DYLDLINK NO_REEXPORTED_DYLIBS

reveals that libxml2-2.9.2_0 built on Yosemite is linking its shared libraries with "-flat_namespace" as seen from the missing TWOLEVEL flag expected from "-undefined dynamic_lookup".

Change History (4)

comment:1 Changed 3 years ago by larryv (Lawrence Velázquez)

  • Description modified (diff)
  • Owner changed from macports-tickets@… to larryv@…
  • Status changed from new to assigned

comment:2 Changed 3 years ago by larryv (Lawrence Velázquez)

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 3 years ago by larryv (Lawrence Velázquez)

comment:4 Changed 3 years ago by ned-deily (Ned Deily)

I believe this was also the root cause of #45553.

Note: See TracTickets for help on using tickets.