Opened 5 years ago

Closed 5 years ago

#48263 closed defect (duplicate)

py27-numpy +universal doesn't build universal

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: Cc: dh@…
Port: py-numpy

Description

I noticed this on my Leopard box. py27+unviersal isn't universal. It isn't even MacPorts' configured default architecture. It's building as just the compiler's default architecture.

~ $ file /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so
/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so: Mach-O i386 bundle

~ $ port provides /opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so
/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/numpy/core/multiarray.so is provided by: py27-numpy

~ $ ls /opt/local/var/macports/software/py27-numpy/
py27-numpy-1.9.2_0+gfortran+universal.darwin_9.i386-x86_64.tbz2

Attachments (1)

main.log (840.2 KB) - added by jeremyhu (Jeremy Huddleston Sequoia) 5 years ago.
main.log

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Attachment: main.log added

main.log

comment:1 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The -universal variant results in the correct architecture (just x86_64), so r138343 for now to at least have a correct port that doesn't support universal rather than a broken one that claims to.

comment:2 Changed 5 years ago by michaelld (Michael Dickens)

Resolution: duplicate
Status: newclosed

Thanks for adding in that change; better to force native arch than allow borked universal; I should have done that long ago (brain fart). Also, this is a duplicate of #42416.

Note: See TracTickets for help on using tickets.