Opened 6 years ago

Closed 4 years ago

#49379 closed defect (fixed)

openmotif: xorg-libXt must be installed with +flat_namespace

Reported by: Garfield-fr (Bertrand Zuchuat) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: snarkhunter (Steve Langer), cssdev, j-beda
Port: openmotif

Description

Hi,

The last upgrade of xorg-libXt failed with message:

Error: org.macports.archivefetch for port openmotif returned: xorg-libXt must be installed with +flat_namespace.

Error log:

version:1
:msg:main --->  Computing dependencies for openmotif:info:main .:debug:main Checking for conflicts against openmotif
:debug:main Searching for dependency: lesstif
:debug:main Didn't find receipt, going to depspec regex for: lesstif
:debug:main Searching for dependency: pkgconfig
:debug:main Found Dependency: receipt exists for pkgconfig
:debug:main Searching for dependency: xbitmaps
:debug:main Found Dependency: receipt exists for xbitmaps
:debug:main Searching for dependency: autoconf
:debug:main Found Dependency: receipt exists for autoconf
:debug:main Searching for dependency: automake
:debug:main Found Dependency: receipt exists for automake
:debug:main Searching for dependency: libtool
:debug:main Found Dependency: receipt exists for libtool
:debug:main Searching for dependency: bison
:debug:main Found Dependency: receipt exists for bison
:debug:main Searching for dependency: flex
:debug:main Found Dependency: receipt exists for flex
:debug:main Searching for dependency: jpeg
:debug:main Found Dependency: receipt exists for jpeg
:debug:main Searching for dependency: libpng
:debug:main Found Dependency: receipt exists for libpng
:debug:main Searching for dependency: libiconv
:debug:main Found Dependency: receipt exists for libiconv
:debug:main Searching for dependency: xorg-libsm
:debug:main Found Dependency: receipt exists for xorg-libsm
:debug:main Searching for dependency: xorg-libXext
:debug:main Found Dependency: receipt exists for xorg-libXext
:debug:main Searching for dependency: Xft2
:debug:main Found Dependency: receipt exists for Xft2
:debug:main Searching for dependency: xorg-libXmu
:debug:main Found Dependency: receipt exists for xorg-libXmu
:debug:main Searching for dependency: xorg-libXp
:debug:main Found Dependency: receipt exists for xorg-libXp
:debug:main Searching for dependency: xorg-libXt
:debug:main Found Dependency: receipt exists for xorg-libXt
:msg:main 
:debug:main Executing org.macports.main (openmotif)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:archivefetch archivefetch phase started at Fri Oct 23 07:43:36 CEST 2015
:msg:archivefetch --->  Fetching archive for openmotif
:debug:archivefetch Executing proc-pre-org.macports.archivefetch-archivefetch-0
:debug:archivefetch Active variants check for archivefetch-type install considers depends_lib depends_run: jpeg libpng libiconv xorg-libsm xorg-libXext Xft2 xorg-libXmu xorg-libXp xorg-libXt
:debug:archivefetch xorg-libXt is installed with the following variants: 
:debug:archivefetch   required: flat_namespace, forbidden: 
:debug:archivefetch   rejected, because required variant flat_namespace is missing
:error:archivefetch org.macports.archivefetch for port openmotif returned: xorg-libXt must be installed with +flat_namespace.
:debug:archivefetch Error code: NONE
:debug:archivefetch Backtrace: xorg-libXt must be installed with +flat_namespace.
    while executing
"proc-pre-org.macports.archivefetch-archivefetch-0 org.macports.archivefetch"
    ("eval" body line 1)
    invoked from within
"eval $pre $targetname"
:info:archivefetch Warning: targets not executed for openmotif: org.macports.install org.macports.archivefetch org.macports.fetch org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot
:notice:archivefetch Please see the log file for port openmotif for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_openmotif/openmotif/main.log

Change History (11)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

This error message is telling you that to solve the problem you should run the following command:

sudo port install xorg-libXt +flat_namespace

Did you try that?

comment:2 Changed 6 years ago by Garfield-fr (Bertrand Zuchuat)

This solution work perfectly.

Thank's for your help.

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: xorg-libXt removed
Port: openmotif added
Resolution: invalid
Status: newclosed
Summary: Upgrade failed on xorg-libXt packageopenmotif: xorg-libXt must be installed with +flat_namespace

Ok, then this is not a bug; it's working as intended.

comment:4 Changed 6 years ago by snarkhunter (Steve Langer)

I think it's a bug. xorg-libXt is probably not often installed directly, but many other ports depend on it. Everyone who wants to install ghostscript shouldn't have to manually install xorg-libXt with unintuitive options. It may not be a bug in xorg-libXt, but it's a bug nonetheless.

comment:5 Changed 6 years ago by snarkhunter (Steve Langer)

Cc: stephen.langer@… added

Cc Me!

comment:6 in reply to:  3 Changed 6 years ago by cannon@…

Resolution: invalid
Status: closedreopened

Replying to ryandesign@…:

I strongly disagree. When running an install of grace, the grace installation fails with the message:

"org.macports.archivefetch for port openmotif returned: xorg-libXt must be installed with +flat_namespace."

and the only way to solve this is to paste the error into a search-engine to find this page and the solution. Shouldn't Macports pull such dependencies automatically? Or at the very least include an intuitive copy-and-pasteable message telling the user what to do?

comment:7 Changed 6 years ago by cssdev

Cc: css@… added

Cc Me!

comment:8 Changed 5 years ago by drs@…

I too encountered this problem. I start with neither openmotif nor xorg-libXt installed. Despite the fact that the openmotif Portfile contains details that the '+flat_namespace' variant of xorg-libXt is required, and even though xorg-libXt has not previously been installed, macports goes ahead with a default installation of xorg-libXt and then proceeds to tell me that I should have specified the '+flat_namespace' variant (see below). This seems like a bug to me as well... at a minimum, it is a waste of the user's time.

bash# port installed | egrep 'xorg-libXt|openmotif'
bash# port install openmotif
--->  Computing dependencies for openmotif
--->  Dependencies to be installed: xorg-libXmu xorg-libXt
--->  Fetching distfiles for xorg-libXt
--->  Verifying checksums for xorg-libXt
--->  Extracting xorg-libXt
--->  Applying patches to xorg-libXt
--->  Configuring xorg-libXt
--->  Building xorg-libXt
--->  Staging xorg-libXt into destroot
--->  Installing xorg-libXt @1.1.5_1
--->  Activating xorg-libXt @1.1.5_1
--->  Cleaning xorg-libXt
--->  Fetching distfiles for xorg-libXmu
--->  Verifying checksums for xorg-libXmu
--->  Extracting xorg-libXmu
--->  Configuring xorg-libXmu
--->  Building xorg-libXmu
--->  Staging xorg-libXmu into destroot
--->  Installing xorg-libXmu @1.1.2_0
--->  Activating xorg-libXmu @1.1.2_0
--->  Cleaning xorg-libXmu
Error: org.macports.archivefetch for port openmotif returned: xorg-libXt must be installed with +flat_namespace.
Please see the log file for port openmotif for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openmotif/openmotif/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port openmotif failed
bash# 

comment:9 in reply to:  8 Changed 5 years ago by j-beda

Replying to drs@…:

...goes ahead with a default installation of xorg-libXt and then proceeds to tell me that I should have specified the '+flat_namespace' variant. This seems like a bug to me as well

I agree. If a fresh empty MacPorts installation of some port 'A' results in an error saying "the dependant port 'B' should have been installed some other way", since it was 'A' that installed 'B', isn't that a failure of the port 'A'?

Is it not possible to have have the openmotif port install 'xorg-libXt +flat_namespace' if the xorg-libXt port is not already installed, and only throw up the error if xorg-libXt is previously installed without the +flat_namespace variant?

Last edited 5 years ago by j-beda (previous) (diff)

comment:10 Changed 5 years ago by j-beda

Cc: j-beda added

comment:11 Changed 4 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: reopenedclosed

In dc7b13e1dca14faef0d56c1a750524f66893810f/macports-ports:

openmotif: update to 2.3.8

No longer requires libXt to be built with flat namespace.

Fixes: #49379

Note: See TracTickets for help on using tickets.