Opened 5 years ago

Closed 5 years ago

#49893 closed defect (duplicate)

grace fails on El Cap

Reported by: basmac Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: GiovanniBussi (Giovanni)
Port: grace

Description (last modified by ryandesign (Ryan Schmidt))

mac16:Publicmac apsd$ xmgrace

Oops! Got SIGSYS

Please use "Help/Comments" to report the bug.
Abort trap: 6
mac16:Publicmac

Copy over the xmgrace from a 10.10 macports install and it works fine on 10.11

Attachments (2)

Portfile (2.6 KB) - added by GiovanniBussi (Giovanni) 5 years ago.
diff (546 bytes) - added by GiovanniBussi (Giovanni) 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: elcapitan added; grace El Cap removed

Changed 5 years ago by GiovanniBussi (Giovanni)

Attachment: Portfile added

comment:2 Changed 5 years ago by GiovanniBussi (Giovanni)

It looks like adding --with-bundled-t1lib=yes to configure.args solves the problem, see the attached Portfile

comment:3 Changed 5 years ago by GiovanniBussi (Giovanni)

Cc: giovanni.bussi@… added

Cc Me!

comment:4 in reply to:  2 Changed 5 years ago by mf2k (Frank Schima)

Replying to giovanni.bussi@…:

see the attached Portfile

Thanks. Per the guidelines, please instead attach a unified diff of the Portfile so we can easily see what changes you are proposing.

Changed 5 years ago by GiovanniBussi (Giovanni)

Attachment: diff added

comment:5 Changed 5 years ago by GiovanniBussi (Giovanni)

I attached the diff file. This just instructs grace to use the bundled t1lib.

comment:6 Changed 5 years ago by mf2k (Frank Schima)

Maybe adding a dependency on Macports t1lib would work instead?

xmgrace runs fine for me without any t1lib.

comment:7 Changed 5 years ago by GiovanniBussi (Giovanni)

If you install xmgrace on a system where t1lib is present without specifying --with-bundled-t1lib=yes, then xmgrace is going to link to the available t1lib.

The problem that I experienced was that t1lib on macports make xmgrace crash. I guess this is due to a bug in t1lib.

The following solutions were proposed: https://trac.macports.org/ticket/47122 uninstall t1lib, then install grace https://trac.macports.org/ticket/45582 install grace +universal

I think that making xmgrace explicitly ignore a possibly installed t1lib is a cleaner solution.

comment:8 Changed 5 years ago by mf2k (Frank Schima)

Keywords: elcapitan removed
Resolution: duplicate
Status: newclosed

Duplicate of #45582. Let's move all discussion there.

Note: See TracTickets for help on using tickets.