Opened 6 years ago

Closed 6 years ago

#50107 closed defect (duplicate)

AquaTerm: build failure on El Capitan

Reported by: jam@… Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: elcapitan Cc: g5pw (Aljaž Srebrnič)
Port: aquaterm

Description

There are several tickets marked as duplicate or selfupdate solves but gnuplot does not build on el Capitan Several clean (format disk, case sensitive and not) installs, install xcode, do command line tools and license bit, the build fails building aquaterm. Macports from dmg and selfupdate. The logged command that fails when cut and paste builds without complaint. Some ports do build eg wget, some do not (I will file a ticket) eg qt5

Attachments (1)

main.log (31.3 KB) - added by jam@… 6 years ago.
log

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by jam@…

I neglected to mention repeat on yosemite and all works perfectly

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: elcapitan added
Owner: changed from macports-tickets@… to mojca@…
Port: gnuplot added

Please attach the main.log file that shows the failure to build gnuplot.

Changed 6 years ago by jam@…

Attachment: main.log added

log

comment:3 Changed 6 years ago by jam@…

attach log

comment:4 Changed 6 years ago by mojca (Mojca Miklavec)

Cc: g5pw@… added
Port: aquaterm added; gnuplot removed
Resolution: duplicate
Status: newclosed
Summary: gnuplot el CapitanAquaTerm: build failure on El Capitan
Version: 2.3.4

This is a duplicate of #50040.

The easiest temporary workaround is probably to compile

sudo port install gnuplot -aquaterm

and use wxt (or qt if it compiles) or x11 as the plotting terminal. The wxt/qt terminal is more feature rich anyway.

Note: See TracTickets for help on using tickets.