New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #5090 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

NEW: mdk-1.2.1

Reported by: aconchillo@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: markd@…
Port:

Description

mdk-1.2.1

the portfile can be found here: http://hacks-galore.org/aleix/mdk.tar.gz

Description:

A set of utilities for developing programs using MIX and MIXAL, including a virtual machine.

The MIX is Donald Knuth's mythical computer, described in the first volume of The Art of Computer Programming, which is programmed using MIXAL, the MIX assembly language.

I have patched the configure.in file as it used old darwin gcc flag (-traditional-cpp). I have also added a foo.c to cheat "ar" when creating the libreplace.a (for getopt_long). In other systems, such as Debian GNu/Linux, "ar" can create empty libraries.

Homepage: http://www.gnu.org/software/mdk/mdk.html

Comments:

This is my first port so any points or comments would be really appreciated.

The port has a "gui" variant, by default only command line applications are installed.

Attachments

mdk-1.tar.gz (2.4 KB) - added by aconchillo@… 10 years ago.
mdk 1.2.1-1
mdk-2.tar.gz (2.3 KB) - added by aconchillo@… 10 years ago.
mdk 1.2.1-2

Change History

Changed 10 years ago by aconchillo@…

mdk 1.2.1-1

Changed 10 years ago by aconchillo@…

mdk 1.2.1-2

comment:1 Changed 10 years ago by aconchillo@…

  • attachments.isobsolete changed from 0 to 1

comment:2 Changed 9 years ago by markd@…

  • Cc markd@… added

(In reply to comment #2)

Created an attachment (id=4044) [edit] mdk 1.2.1-2

This revision correctly resolves the bug (confirmed by the author) found in revision 1.

Good work, thank you! Committed.

comment:3 Changed 9 years ago by blb@…

  • Status changed from new to closed
  • Resolution set to fixed

Resolving since markd@ committed.

Note: See TracTickets for help on using tickets.