Opened 3 years ago

Closed 3 years ago

#51142 closed defect (invalid)

ghostscript: build fails when Xcode.app is renamed so that it contains a space

Reported by: ssisak (Steve Sisak) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: ghostscript

Description (last modified by ryandesign (Ryan Schmidt))

I just attempted a clean install of MacPorts (never installed) then ImageMagick -- Xcode 7.3 release

Install failed with ghostscript, did a clean and reinstall of ghostscript alone

Install failed with:

MBP-R:~ sgs$ sudo port install ghostscript
--->  Computing dependencies for ghostscript
--->  Building ghostscript
Error: org.macports.build for port ghostscript returned: command execution failed
Please see the log file for port ghostscript for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_print_ghostscript/ghostscript/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port ghostscript failed

Attachments (1)

main.log (56.5 KB) - added by ssisak (Steve Sisak) 3 years ago.
Failure log

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by ssisak (Steve Sisak)

Attachment: main.log added

Failure log

comment:1 Changed 3 years ago by ssisak (Steve Sisak)

Scouring the log a bit more, I think I found the cause and a workaround.

If you look near the end of the log, you'd see it dies trying ti access /Application/Xcode

As a developer, I have multiple version of Xcode installed and the active version was renamed "Xcode 7.3"

I tried making an alias named Xcode and then "Xcode"pointing to the original install, which failed with a permissions error.

I finally renamed "Xcode 7.3.app" back to "Xcode.app" and ghostscript built as did the rest of ImageMagick.

I haven't dug into the port, but I'm guessing there's either a hard-coded path to Xcode (rather than using the tools) or a quoting error because of the space in the name.

Hopefully this is enough to reproduce the problem.

HTH,

-Steve

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: ElCapitan removed
Resolution: invalid
Status: newclosed
Summary: port install ghostscript fails on 10.11.4ghostscript: build fails when Xcode.app is renamed so that it contains a space

This problem occurred because you renamed Xcode containing a space. Don't do that. Spaces in paths cause problems for lots of UNIX software.

Note: See TracTickets for help on using tickets.