Opened 3 years ago

Closed 3 years ago

#51144 closed defect (fixed)

libgdata fails to build with vala-0.32 update

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: vala libgdata

Description

libgdata is failing to compile for me on a recent from-scratch installation. I suspect this may be due to vala-0.32 changes:

make[2]: Entering directory `/opt/local/var/macports/build/_Users_jeremy_src_macports_trunk_dports_gnome_libgdata/libgdata/work/libgdata-0.17.4'
/opt/local/bin/vapigen-0.32  --library gdata/libgdata --metadatadir ./gdata   --pkg libxml-2.0 --pkg libsoup-2.4 --pkg json-glib-1.0 gdata/GData-0.0.gir
libsoup-2.4.vapi:1134.3-1134.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1248.3-1248.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1898.3-1898.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1901.3-1901.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1904.3-1904.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1907.3-1907.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1910.3-1910.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1913.3-1913.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1916.3-1916.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1919.3-1919.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1922.3-1922.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1925.3-1925.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1958.3-1958.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1961.3-1961.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:1964.3-1964.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2034.3-2034.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2038.3-2038.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2041.3-2041.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2044.3-2044.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2047.3-2047.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2050.3-2050.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2053.3-2053.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2056.3-2056.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2059.3-2059.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2062.3-2062.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2065.3-2065.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
libsoup-2.4.vapi:2069.3-2069.12: warning: [Deprecated] is deprecated. Use [Version (deprecated = true, deprecated_since = "", replacement = "")]
GData-0.0.gir:20804.55-20804.55: error: The symbol `Goa' could not be found
            <type name="Goa.Object" c:type="GoaObject*"/>
                                                      ^
GData-0.0.gir:20814.53-20814.53: error: The symbol `Goa' could not be found
          <type name="Goa.Object" c:type="GoaObject*"/>
                                                    ^
GData-0.0.gir:20829.30-20829.30: error: The symbol `Goa' could not be found
        <type name="Goa.Object"/>
                             ^
GData-0.0.gir:20829.30-20829.30: error: The symbol `Goa' could not be found
        <type name="Goa.Object"/>
                             ^
GData-0.0.gir:20829.30-20829.30: error: The symbol `Goa' could not be found
        <type name="Goa.Object"/>
                             ^
Generation failed: 5 error(s), 27 warning(s)
make[2]: *** [gdata/libgdata.vapi] Error 1

Change History (2)

comment:1 Changed 3 years ago by dbevans (David B. Evans)

The issue is that libgdata now needs goa-1.0 added to its vapi dependencies. Not sure where this was coming from before but current versions of gnome-online-accounts now provide these bindings separately.

Fix committed in r147746.

comment:2 Changed 3 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

gnome-online-accounts legacy version 3.8.5, which is built for older platforms that don't support libc++, does not provide the goa-1.0 vala bindings causing build failures on those platforms in spite of the previous fix.

libgdata goa support disabled for these platforms (typically 10.8 and earlier) in r147747.

Note: See TracTickets for help on using tickets.