Opened 5 years ago

Closed 5 years ago

#51179 closed defect (invalid)

ImageMagick @6.9.3-4_1 build error

Reported by: kakearney@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: ImageMagick

Description

Attempting to build ImageMagick 6.9.3-4 fails on my system (OS X 10.11.4, El Capitan, XCode 7.3). Full log is attached.

Error message:

--->  Computing dependencies for ImageMagick
--->  Building ImageMagick
Error: org.macports.build for port ImageMagick returned: command execution failed
Please see the log file for port ImageMagick for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_ImageMagick/ImageMagick/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port ImageMagick failed

Attachments (1)

main.log (79.4 KB) - added by kakearney@… 5 years ago.
Log file

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by kakearney@…

Attachment: main.log added

Log file

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…

comment:2 Changed 5 years ago by cytan299

Same problem here. Looks like the problem is that /usr/local/lib/libgomp.dylib is missing although libgomp.1.dylib exists. I did a

ln -s libgomp.1.dylib libgomp.dylib

and the build worked.

This may not be the best way though ...

Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 Changed 5 years ago by cytan299

I have a very weird observation:

I have built ImageMagick on two different Macs: an iMac and a MacBook Pro.

On the iMac, ImageMagick builds fine. BUT there is no libgomp libraries in the /usr/local/lib directory!

While on the MacBookPro libgomp exists.

Both machines run El Capitan 10.11.4 and

Apple LLVM 7.3.0 (clang-703.0.29)

Weird!!!!

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

It is unsupported to have things installed in /usr/local while using MacPorts, because of the likelihood of this kind of problem. See wiki:FAQ#usrlocal.

Note: See TracTickets for help on using tickets.