Opened 5 years ago

Closed 5 years ago

#51558 closed defect (invalid)

qgis 2.14.2 fails to configure because qca-ossl is not found

Reported by: flx.ms@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: qgis

Description

Configuring qgis (with vriants +grass +postgresql95) fails because "QCA OpenSSL plugin not found". Similar problems have been reported in ticket #50486 and #50496. In contrast to #50486 I did not experience any problems in building qca-ossl. I am working under Yosemite 10.10.5 with macports 2.3.4 (latest version).

After selfupdate I forced unistallation of qca-ossl, qca and qwt61, cleand everything and tried to build again. Unfortunately in vain.

The main log of the failed build process is attached.

I'd appreciate any hint, how to solve the problem very much. Best, Felix

Attachments (5)

main.log (196.2 KB) - added by flx.ms@… 5 years ago.
Main log of qgis configure/build process
main.2.log (196.2 KB) - added by flx.ms@… 5 years ago.
CMakeError.log (6.5 KB) - added by flx.ms@… 5 years ago.
CMakeOutput.log (42.0 KB) - added by flx.ms@… 5 years ago.
main.3.log (196.0 KB) - added by flx.ms@… 5 years ago.
main log for qgis 2.14.3

Download all attachments as: .zip

Change History (22)

Changed 5 years ago by flx.ms@…

Attachment: main.log added

Main log of qgis configure/build process

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: vince@… removed
Owner: changed from macports-tickets@… to vince@…

comment:2 Changed 5 years ago by Veence (Vincent)

Strange, can you report what

port installed | grep qca

returns? Thanks!

comment:3 Changed 5 years ago by flx.ms@…

Thank you for trying to help me out! Really strange, never experienced any problems with qgis so far.

"port installed | grep qca" returns

qca @2.1.0_2+qt4 (active) qca-gnupg @2.1.0_2+qt4 (active) qca-ossl @2.1.0_2+qt4 (active)

greetings, flx

comment:4 Changed 5 years ago by Veence (Vincent)

I wonder if that’s not caused by qca-gnupg interfering with qca-ossl. Can you deactivate qca-gnupg and try again?

comment:5 Changed 5 years ago by flx.ms@…

Unfortunately neither deactivating qca-gnupg nor deinstallation of qca-gnupg helped. Both build processes resulted in the very same error during configure again: "QCA OpenSSL plugin not found (run-time/unit-test dependency)" (see main.log attached)

Changed 5 years ago by flx.ms@…

Attachment: main.2.log added

comment:6 Changed 5 years ago by flx.ms@…

ls /opt/local/lib/libqc* returns

/opt/local/lib/libqca.2.1.0.dylib /opt/local/lib/libqca.2.dylib /opt/local/lib/libqca.2.1.dylib /opt/local/lib/libqca.dylib

is there something missing?

comment:7 Changed 5 years ago by flx.ms@…

At least one other user seems to face the same problem: #51561.

comment:8 Changed 5 years ago by Veence (Vincent)

try

ls -l /opt/local/lib/libqca.*

It should point to /opt/local/Library/Frameworks/qca.framework/Versions/2.1.0/qca

comment:9 Changed 5 years ago by flx.ms@…

ls -l /opt/local/lib/libqca.* returns

/opt/local/lib/libqca.2.1.0.dylib -> /opt/local/Library/Frameworks/qca.framework/Versions/2.1.0/qca /opt/local/lib/libqca.2.1.dylib -> /opt/local/Library/Frameworks/qca.framework/Versions/2.1.0/qca /opt/local/lib/libqca.2.dylib -> /opt/local/Library/Frameworks/qca.framework/Versions/2.1.0/qca /opt/local/lib/libqca.dylib -> /opt/local/Library/Frameworks/qca.framework/Versions/2.1.0/qca

so it looks OK(?).

comment:10 Changed 5 years ago by Veence (Vincent)

As suggested by the main.log, can you upload the contents of

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gis_qgis/qgis/work/qgis-2.14.2/build/CMakeFiles/CMakeError.log

Thanks!

Changed 5 years ago by flx.ms@…

Attachment: CMakeError.log added

comment:11 Changed 5 years ago by flx.ms@…

Of course! Please find the requested file attached...

Changed 5 years ago by flx.ms@…

Attachment: CMakeOutput.log added

comment:12 Changed 5 years ago by flx.ms@…

Attached CmakeOutput.log as well. Maybe the files of the closed duplicate #51561 give additional insight into the problem?

comment:13 Changed 5 years ago by zxrobinson

I reported #51561. I've been following along. I don't have qca-gnupg installed. Otherwise, my results are the same. Haven't compared my logs to these though.

comment:14 Changed 5 years ago by Veence (Vincent)

I’ve updated to 2.14.3. Is the bug still there?

comment:15 Changed 5 years ago by flx.ms@…

Yes, unfortunately the bug remains.

Changed 5 years ago by flx.ms@…

Attachment: main.3.log added

main log for qgis 2.14.3

comment:16 Changed 5 years ago by Veence (Vincent)

I am going to disable the test for qca-ossl since it is required as a dependency by the Portfile anyway.

comment:17 Changed 5 years ago by Veence (Vincent)

Resolution: invalid
Status: newclosed

Please retry with the new 2.16 version and re open a bug report if necessary.

Note: See TracTickets for help on using tickets.