Opened 2 years ago

Closed 2 years ago

#52209 closed defect (fixed)

go @1.7 fails to build on macOS Sierra

Reported by: marcel@… Owned by: ci42
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: eric@…, josephwinston (Joseph Winston), fleason (Fred Leason), john@…
Port: go

Description

Please see attached build log.

Attachments (2)

main.log (8.9 KB) - added by marcel@… 2 years ago.
main.2.log (45.1 KB) - added by marcel@… 2 years ago.

Download all attachments as: .zip

Change History (18)

Changed 2 years ago by marcel@…

Attachment: main.log added

comment:1 Changed 2 years ago by larryv (Lawrence Velázquez)

This log is not from a clean build. Please run sudo port clean go and try again.

comment:2 Changed 2 years ago by marcel@…

I have done that and have attached the log of the failed build.

Changed 2 years ago by marcel@…

Attachment: main.2.log added

comment:3 Changed 2 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to ciserlohn@…

Looks related to #52041?

comment:4 Changed 2 years ago by eric@…

Cc: eric@… added

Cc Me!

comment:5 Changed 2 years ago by carlos.abalde@…

Cc Me!

comment:6 in reply to:  5 ; Changed 2 years ago by larryv (Lawrence Velázquez)

Cc: carlos.abalde@… added

You have to actually click the “CcMe!” button near the top of the ticket.

comment:7 Changed 2 years ago by carlos.abalde@…

Cc: carlos.abalde@… removed

Cc Me!

comment:8 in reply to:  6 Changed 2 years ago by carlos.abalde@…

Sorry! First time here. Thx!

comment:9 Changed 2 years ago by radaroutthere@…

Cc: radaroutthere@… added

Cc Me!

comment:10 Changed 2 years ago by josephwinston (Joseph Winston)

Cc: josephwinston@… added

Cc Me!

comment:11 Changed 2 years ago by fleason (Fred Leason)

Cc: fleason@… added

Cc Me!

comment:12 Changed 2 years ago by john@…

Cc: john@… added

Cc Me!

comment:13 Changed 2 years ago by radaroutthere@…

Cc: radaroutthere@… removed

Cc Me!

comment:14 in reply to:  3 Changed 2 years ago by ryandesign (Ryan Schmidt)

Replying to larryv@…:

Looks related to #52041?

The error message is the same ("fatal error: MSpanList_Insert") but #52041 is about the go-1.4 port while this ticket is about the go port. #52041 has been resolved. Did that help?

comment:15 in reply to:  11 Changed 2 years ago by fleason (Fred Leason)

Replying to fleason@…:

Cc Me!

It just installed with standard updates.

comment:16 Changed 2 years ago by ci42

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.