Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#53322 closed defect (fixed)

some requested variants are lost in dependencies of ports that have +universal added by arch checking

Reported by: mf2k (Frank Schima) Owned by: jmroot (Joshua Root)
Priority: Normal Milestone: MacPorts 2.4.0
Component: base Version: 2.3.99
Keywords: Cc:
Port:

Description (last modified by mf2k (Frank Schima))

Using the latest base from git, port does not seem to honor the variants specified in my variants.conf file. You can see this when installing wine-devel from scratch. Even though I have +python35 in my variants.conf, some ports will have the +python27 variant (the default for the ports) installed instead. I think the variants are getting cleared at some point in the install process.

Change History (7)

comment:1 Changed 7 months ago by mf2k (Frank Schima)

2 ports with python variants that get +python27 instead of +python35 are xorg-libxcb and xorg-xcb-proto.

comment:2 Changed 7 months ago by mf2k (Frank Schima)

  • Description modified (diff)

comment:3 Changed 7 months ago by jmroot (Joshua Root)

Can't reproduce with a couple of simple test ports. Can you bisect and/or find a smaller example than wine-devel?

comment:4 Changed 7 months ago by jmroot (Joshua Root)

  • Summary changed from port does not honor variants in variants.conf to some requested variants are lost in dependencies of ports that have +universal added by arch checking

Never mind, I think I figured it out based on the fact that wine-devel exhibits the problem and most other ports do not.

comment:5 Changed 7 months ago by jmroot (Joshua Root)

  • Owner set to jmroot
  • Resolution set to fixed
  • Status changed from new to closed

In 4972592/macports-base:

Fix variant bug with auto-adding +universal

All requested variants were not passed down to dependencies in this case, but
only those that existed in the port that was having +universal added.

Fixes: #53322

comment:6 Changed 7 months ago by jmroot (Joshua Root)

  • Milestone set to MacPorts 2.4.0

comment:7 Changed 7 months ago by mf2k (Frank Schima)

I confirmed that this worked for me. Thank you.

Note: See TracTickets for help on using tickets.