Opened 5 years ago

Closed 5 years ago

#53323 closed defect (fixed)

suck @4.3.2_3 "Error: org.macports.build for port suck returned: command execution failed" due to "fatal error: 'phrases.h' file not found"

Reported by: dclunie Owned by: springer.jonathan@…
Priority: Normal Milestone:
Component: ports Version: 2.3.5
Keywords: Cc:
Port: suck

Description (last modified by ryandesign (Ryan Schmidt))

Was doing a "port upgrade outdated", with an older version of suck installed.

Got:

Error: org.macports.build for port suck returned: command execution failed
Please see the log file for port suck for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_suck/suck/main.log

Tried

port install suck

Got same error.

Dumped the log file specified (attached(, and found lots of

fatal error: 'phrases.h' file not found

messages during compilation.

Manually changed to working directory, and did a make phrases.h, then repeated port install suck and it installed and worked OK.

Am on OS X Yosemite 10.10.5

Attachments (1)

main.log.gz (2.2 KB) - added by dclunie 5 years ago.
log file during build

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by dclunie

Attachment: main.log.gz added

log file during build

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: set to springer.jonathan@…
Port: suck added
Status: newassigned

This is a parallel build problem. We can work around it by disabling parallel building.

The project appears to be abandoned (its homepage disappeared years ago already), otherwise I would have suggested that the developers should fix their Makefile dependency rules.

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

In b4d4a6c/macports-ports:

suck: Disable parallel building

Closes: #53323

Note: See TracTickets for help on using tickets.