Opened 15 years ago

Closed 15 years ago

#5339 closed defect (fixed)

BUG: upgrade to DarwinPorts 1.102 fails on OSX 10.4.2

Reported by: liamr@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc: mww@…
Port:

Description

Fresh install of the DarwinPorts-1.1.dmg image file on OS X 10.4.2, 12" 1.33Ghz G4 PowerBook.

When I run "port selfupdate", I get:

cc -dynamiclib -L/usr/lib -lcurl -lssl -lcrypto -lz darwinports.o portconf.o session.o util.o -o Darwinports.dylib -L/System/Library/Frameworks/Tcl.framework/Versions/8.4 -ltclstub8.4 -lcrypto /usr/bin/libtool: for architecture: cputype (16777234) cpusubtype (0) file: -lSystem is not an object file (not allowed in a library) make[2]: * [Darwinports.dylib] Error 1 make[1]: * [all] Error 1 make: * [all] Error 1

Change History (3)

comment:1 Changed 15 years ago by blb@…

First thing, make sure you have Xcode 2.0 or 2.1 installed for your devtools instead of an older (10.3- era) version, as that's usually the issue with this error message.

comment:2 Changed 15 years ago by mww@…

Cc: mww@… added
Summary: upgrade to DarwinPorts 1.102 fails on OSX 10.4.2BUG: upgrade to DarwinPorts 1.102 fails on OSX 10.4.2

comment:3 Changed 15 years ago by liamr@…

Resolution: fixed
Status: newclosed

Upgrading Xcode fixed the issue.

Note: See TracTickets for help on using tickets.