Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#56095 closed defect (duplicate)

xercesc3: duplicate symbol xercesc_3_2::ArrayJanitor<unsigned char>::ArrayJanitor(unsigned char*)

Reported by: MarcChenevier Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: tiger leopard snowleopard Cc:
Port: xercesc3

Description (last modified by Schamschula (Marius Schamschula))

:error:build Failed to build xercesc3: command execution failed
:debug:build Error code: CHILDSTATUS 372 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:debug:build Failed to locate 'lbzip2' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?
:debug:build     while executing
:debug:build "error "$eMessage or at its MacPorts configuration time location, did you move it?""
:debug:build     invoked from within
:debug:build "try -pass_signal {
:debug:build             set cmd_path [macports::binaryInPath $prog]
:debug:build             return $cmd_path
:debug:build         } catch {{*} eCode eMessage} {
:debug:build        ..."
:debug:build     (procedure "macports::findBinary" line 5)
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_ta:

Attachments (2)

report failure to build xercesc3 (11.5 KB) - added by MarcChenevier 3 years ago.
copy of terminal
fichierlog.log (62.8 KB) - added by MarcChenevier 3 years ago.
copy of main.log

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by MarcChenevier

copy of terminal

comment:1 Changed 3 years ago by Schamschula (Marius Schamschula)

Description: modified (diff)

comment:2 Changed 3 years ago by Schamschula (Marius Schamschula)

Keywords: xercesc3 removed
Port: xercesc3 added; nco removed
Summary: failure of port install ncofailure to install xercesc3

Please attach the build log of xercesc3

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Keywords: tiger leopard snowleopard added
Resolution: duplicate
Status: newclosed
Summary: failure to install xercesc3xercesc3: duplicate symbol xercesc_3_2::ArrayJanitor<unsigned char>::ArrayJanitor(unsigned char*)
Type: requestdefect

An incomplete log is already attached, which is enough to see that the build is on Snow Leopard and that it fails with:

:info:build ld: duplicate symbol xercesc_3_2::ArrayJanitor<unsigned char>::ArrayJanitor(unsigned char*)in xercesc/util/.libs/TransService.o and xercesc/util/.libs/PlatformUtils.o

So this is a duplicate of #55988.

Changed 3 years ago by MarcChenevier

Attachment: fichierlog.log added

copy of main.log

comment:4 Changed 3 years ago by MarcChenevier

Yes thank you it is the same problem I see, but I don't know how build 3.2.1 with the patch of rleigh-codelibre with Snow Leopard, can you explain Thanks, Marc

Note: See TracTickets for help on using tickets.