Opened 3 years ago

Closed 3 years ago

#56193 closed defect (fixed)

volk @1.4 fails to build

Reported by: tehcog (tehcog) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.4.2
Keywords: Cc: Schamschula (Marius Schamschula)
Port: volk

Description

Several errors generated building volk. Please see attached log.

Attachments (1)

main.log (142.7 KB) - added by tehcog (tehcog) 3 years ago.
main.log

Download all attachments as: .zip

Change History (10)

Changed 3 years ago by tehcog (tehcog)

Attachment: main.log added

main.log

comment:1 Changed 3 years ago by hoehenunterschied

build fails on High Sierra as well. The error messages in main.log are identical to the uploaded main.log

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Cc: michaelld removed
Keywords: mavericks removed
Owner: set to michaelld
Status: newassigned

comment:3 Changed 3 years ago by Schamschula (Marius Schamschula)

Cc: Schamschula added

comment:4 Changed 3 years ago by Schamschula (Marius Schamschula)

Summary: volk @1.4 fails to build on mavericksvolk @1.4 fails to build

I get the same failure under High Sierra.

comment:5 Changed 3 years ago by michaelld (Michael Dickens)

... working on it ...

comment:6 Changed 3 years ago by michaelld (Michael Dickens)

... BTW works for me on 10.12 latest ...

comment:7 Changed 3 years ago by michaelld (Michael Dickens)

OK I just pushed a possible fix here: https://github.com/macports/macports-ports/commit/87591c10dc6987d22cd8c372eb405787cf59c7db

Please update & "clean uhd" and see if this fixes the issue for you.

Last edited 3 years ago by michaelld (Michael Dickens) (previous) (diff)

comment:8 Changed 3 years ago by tehcog (tehcog)

Thanks

comment:9 Changed 3 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

Thanks for reporting back.

OK so the issue was for folks upgrading from the 1.3 series to the 1.4 series only. Those installing from scratch should not have encountered this issue. Adding in the prior volk-devel patches fixed an issue with API inclusion, such that the already-installed headers are not used & those internal to the build are.

Note: See TracTickets for help on using tickets.