Opened 2 years ago

Closed 20 months ago

#57107 closed defect (duplicate)

protobuf3-cpp version 3.6.1 conflicts with opencv @3.4.1_2+contrib+python27

Reported by: jtressle Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc:
Port: protobuf3-cpp opencv

Description

Latest version of Opencv with contrib and python27 no longer compiles with protobuf3-cpp.

protobuf3-cpp 3.6.1 causes issues because PROTOBUF_CONSTEXPR is unknown.

Last version of protobuf3-cpp (3.5.1) worked.

Attachments (1)

main.log (822.8 KB) - added by jtressle 2 years ago.
opencv main.log

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by jtressle

Attachment: main.log added

opencv main.log

comment:1 Changed 2 years ago by jtressle

I just now was able to build and install opencv+contrib+python27 by downgrading protobuf3-cpp to version 3.5.1.

comment:2 Changed 2 years ago by jmroot (Joshua Root)

Keywords: protobuf3-cpp opencv removed
Milestone: MacPorts 2.6.0
Owner: set to stromnov
Status: newassigned

comment:3 Changed 2 years ago by jtressle

Any update on this? Same issue has happened on Opencv 3.4.3.

comment:4 Changed 21 months ago by g-raffy

While this gets fixed, I managed to get around this bug by replacing -DBUILD_PROTOBUF=NO with -DBUILD_PROTOBUF=YES in /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/graphics/opencv/Portfile, then rebuilding opencv :

sudo port clean opencv
sudo port install opencv +contrib+java+python27+python36+qt5

Before doing so, make sure protobuf3-cpp is installed so that you have the command protoc to generate the headers compatible with your protobuf library version:

sudo port install protobuf3-cpp

Hope this helps

comment:5 Changed 20 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #56349.

Note: See TracTickets for help on using tickets.