Opened 2 years ago

Closed 2 years ago

Last modified 3 months ago

#57178 closed defect (fixed)

pinentry-mac fails to compile with Xcode 10

Reported by: pmetzger (Perry E. Metzger) Owned by: Ionic (Mihai Moldovan)
Priority: High Milestone:
Component: ports Version:
Keywords: xcode10 Cc:
Port: pinentry-mac

Description

Under Mojave, pinentry-mac fails to compile. Logfile is attached.

This is fairly critical since a lot of ports depend on this port.

Attachments (1)

foo (83.7 KB) - added by pmetzger (Perry E. Metzger) 2 years ago.
main.log from build

Download all attachments as: .zip

Change History (22)

Changed 2 years ago by pmetzger (Perry E. Metzger)

Attachment: foo added

main.log from build

comment:1 Changed 2 years ago by pmetzger (Perry E. Metzger)

Partial fix committed in [f317c0817e4edb9694861fd39394ee5a85b9344f/macports-ports]

However, now destroot is failing.

Last edited 3 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 2 years ago by pmetzger (Perry E. Metzger)

A kluge that works around the destroot problem is now committed in [9cb3c083519503bb4b404fe57f19466a924523be/macports-ports]

A better fix is needed, but this will help people in pain.

Last edited 3 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 Changed 2 years ago by Ionic (Mihai Moldovan)

I'll probably have to update the port anyway (and move more platforms to pinentry, if it turns out that a newer Xcode version is necessary).

comment:4 Changed 2 years ago by mf2k (Frank Schima)

Keywords: xcode10 added
Summary: pinentry-mac fails to compile under Mojavepinentry-mac fails to compile with Xcode 10

comment:5 Changed 2 years ago by mf2k (Frank Schima)

FTR, this happened for me on High Sierra with Xcode 10.

comment:6 Changed 2 years ago by Ionic (Mihai Moldovan)

So indeed an Xcode problem, okay.

comment:7 Changed 2 years ago by pmetzger (Perry E. Metzger)

Ionic, the fixes I put in place will hold everything for now. That said, upstream should commit their pull request to fix the quotes in the include files. The rest seems to be an xcode issue unrelated to pinentry-mac.

comment:8 Changed 2 years ago by pmetzger (Perry E. Metzger)

(If you can get upstream to fix that and do a release that would be good.)

comment:9 Changed 2 years ago by Ionic (Mihai Moldovan)

I typically wait until upstream releases a new version (or tags it, for that matter), but that normally takes a few months after the initial OS X release date.

Note that the issue is not as critical as it may seem to be, since users can just switch to pinentry via the provided variants (i.e., -pinentry_mac+pinentry) if they need to. It's just the default selection that might be unfit due to newer OS/toolchain versions.

comment:10 Changed 2 years ago by pmetzger (Perry E. Metzger)

Regardless, it's been fixed for now. The issue of the issue with destroot under Xcode 10 may impact other ports, FWIW.

comment:11 Changed 2 years ago by Schamschula (Marius Schamschula)

Priority: HighNormal

Please don't change the default priority. This field is for MacPorts maintainers only.

comment:12 Changed 2 years ago by pmetzger (Perry E. Metzger)

Priority: NormalHigh

Schamschula, I'm a MacPorts project member. And the problem is high priority, although it's been temporarily patched over, there's an issue here that may hit a bunch of ports. Xcode's new build stuff apparently has some peculiarities.

Last edited 2 years ago by pmetzger (Perry E. Metzger) (previous) (diff)

comment:13 Changed 2 years ago by Schamschula (Marius Schamschula)

Sorry, Perry!

This was a knee jerk reaction to the number of times an insignificant problem is marked high priority.

comment:14 Changed 2 years ago by mf2k (Frank Schima)

I verified that it builds for me on Mojave and Xcode 10. Can we close this as fixed now?

comment:15 Changed 2 years ago by pmetzger (Perry E. Metzger)

Sort of. We might want a distinct ticket to track the overall problem, which has hit other ports too.

comment:16 Changed 2 years ago by ylluminarious (George Plymale II)

Wanted to add that this is fixed for me now, too. I can install pinentry-mac and thus gnupg2 just fine.

comment:17 Changed 2 years ago by mf2k (Frank Schima)

I think this ticket should be closed because it has been fixed and it is High priority.

If you want to create a new ticket for the underlying issue, namely the new build system in Xcode 10, I suggest creating one for that.

comment:18 Changed 2 years ago by mf2k (Frank Schima)

I'm currently working on creating such a ticket...

comment:19 Changed 2 years ago by mf2k (Frank Schima)

It certainly could be improved, but here is that ticket #57234.

comment:20 Changed 2 years ago by pmetzger (Perry E. Metzger)

Resolution: fixed
Status: assignedclosed

comment:21 Changed 2 years ago by pmetzger (Perry E. Metzger)

I've closed it and we'll stick to the new ticket from here.

Note: See TracTickets for help on using tickets.