Opened 2 years ago

Closed 2 years ago

#57183 closed defect (fixed)

gdal @2.3.2 fails to build

Reported by: news24lor Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.5.3
Keywords: Cc: pgf, MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: gdal

Description

New version of gdal 2.3.2 fails to build under OS 10.13.

This is error at the start

...
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/png'
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C rik install-obj
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/rik'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/rik'
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C ozi install-obj
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/ozi'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/ozi'
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C pdf install-obj
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/pdf'
:info:build /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/libtool --mode=compile --silent --tag=CXX /usr/bin/clang++ -std=c++14 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/port -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/gcore -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/alg -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/ogr -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/ogr/ogrsf_frmts -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/gnm -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/apps -DHAVE_AVX_AT_COMPILE_TIME -DHAVE_SSSE3_AT_COMPILE_TIME -DHAVE_SSE_AT_COMPILE_TIME -pipe -DGDAL_COMPILATION -stdlib=libc++ -arch x86_64  -Wall -Wextra -Winit-self -Wunused-parameter -Wformat -Werror=format-security -Wno-format-nonliteral -Wshorten-64-to-32 -Wshadow -Werror=vla -Wdate-time -Wnull-dereference -Wextra-semi -Wcomma -Wfloat-conversion -Wdocumentation -Wno-documentation-deprecated-sync -Wunused-private-field -Wmissing-prototypes -Wmissing-declarations -Wnon-virtual-dtor -Woverloaded-virtual -fno-operator-names -Wzero-as-null-pointer-constant -Wimplicit-fallthrough  -I../vrt -I../mem -I../../ogr/ogrsf_frmts/mem -DGNM_ENABLED -D_REENTRANT -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/port -I/opt/local  -DGDAL_COMPILATION -I/opt/local/include -DHAVE_XERCES -I/opt/local/include -I/opt/local/include/xercesc -D_REENTRANT -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/port -I/opt/local  -DGDAL_COMPILATION -I/opt/local/include -DHAVE_POPPLER -DPOPPLER_HAS_OPTCONTENT -DPOPPLER_BASE_STREAM_HAS_TWO_ARGS -DPOPPLER_0_20_OR_LATER -DPOPPLER_0_23_OR_LATER -DPOPPLER_0_58_OR_LATER -I/opt/local/include -I/opt/local/include/poppler   -DDO_NOT_USE_DEBUG_BOOL -c -o ../o/pdfdataset.lo pdfdataset.cpp
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/pcidsk'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/pcidsk'
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/jpeg'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C rasterlite install-obj
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/jpeg'
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/pcraster'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/pcraster'
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C mbtiles install-obj
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C postgisraster install-obj
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/mbtiles'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/mbtiles'
:info:build /Applications/Xcode.app/Contents/Developer/usr/bin/make -C arg install-obj
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/rasterlite'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/rasterlite'
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/postgisraster'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/postgisraster'
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/arg'
:info:build make[2]: Nothing to be done for `install-obj'.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/arg'
:info:build pdfdataset.cpp:3443:18: error: no viable conversion from 'const std::unordered_map<Ref, std::unique_ptr<OptionalContentGroup> >' to 'GooList *'
:info:build         GooList* ocgList = optContentConfig->getOCGs();
:info:build                  ^         ~~~~~~~~~~~~~~~~~~~~~~~~~~~
:info:build pdfdataset.cpp:3475:18: error: no viable conversion from 'const std::unordered_map<Ref, std::unique_ptr<OptionalContentGroup> >' to 'GooList *'
:info:build         GooList* ocgList = optContentConfig->getOCGs();
:info:build                  ^         ~~~~~~~~~~~~~~~~~~~~~~~~~~~
:info:build 2 errors generated.
:info:build make[2]: *** [../o/pdfdataset.lo] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts/pdf'
:info:build make[1]: *** [pdf-install-obj] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal/frmts'
:info:build make: *** [frmts-target] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-2.3.2/gdal" && /usr/bin/make -j4 -w 
:info:build Exit code: 2
:error:build Failed to build gdal: command execution failed
:debug:build Error code: CHILDSTATUS 13963 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/main.log for details.

Change History (7)

comment:1 Changed 2 years ago by jmroot (Joshua Root)

Cc: Veence removed
Keywords: gis removed
Owner: set to Veence
Port: gdal added; 2.3.2 removed
Status: newassigned
Summary: gdal-2.3.2 fails to buildgdal @2.3.2 fails to build

comment:2 Changed 2 years ago by Veence (Vincent)

What options are you compiling gdal with?

comment:3 Changed 2 years ago by pgf

Cc: pgf added

comment:4 Changed 2 years ago by pgf

It seems that the error is caused by the +poppler variant.

comment:5 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:6 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

There is a pull request that attempts to solve this problem.

comment:7 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.