Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#58140 closed enhancement (fixed)

cpan2port: Use perl5.28

Reported by: hyperbole (hyperbole) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: mojca (Mojca Miklavec)
Port: cpan2port

Description (last modified by ryandesign (Ryan Schmidt))

This is a patch to allow cpan2port to run under Perl 5.28

Attachments (1)

Portfile-cpan2port.diff (456 bytes) - added by hyperbole (hyperbole) 20 months ago.
Patch for cpan2port for Perl 5.28

Download all attachments as: .zip

Change History (4)

Changed 20 months ago by hyperbole (hyperbole)

Attachment: Portfile-cpan2port.diff added

Patch for cpan2port for Perl 5.28

comment:1 Changed 20 months ago by ryandesign (Ryan Schmidt)

Cc: mojca added
Description: modified (diff)
Keywords: haspatch added
Summary: Patch for cpan2port - updates to Perl 5.28cpan2port: Use perl5.28
Type: submissionenhancement

Since this presumably changes the installed files, the revision needs to be increased.

comment:2 Changed 20 months ago by mojca (Mojca Miklavec)

Owner: set to mojca
Resolution: fixed
Status: newclosed

In e02c91a6885378a941366d0a97693e9799d1ca94/macports-ports (master):

cpan2port: switch to and support perl5.28

Closes: #58140

comment:3 Changed 20 months ago by mojca (Mojca Miklavec)

Thanks a lot.

I had to modify cpan2port to also output 5.28 by default, so there was no need for revision bump.

Note: See TracTickets for help on using tickets.