#59226 closed defect (fixed)

libvpx: invalid command name "compiler_blacklist_versions._get_compiler_version"

Reported by: 0az (Andrew Zhou) Owned by: Aaron Madlon-Kay <amake@…>
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc:
Port: libvpx

Description

The libvpx port cannot be opened due to containing an invalid command name compiler_blacklist_versions._get_compiler_version.

This breaks info/install/uninstall/upgrades.

As the relevant line in libvpx has not been changed for a few years, I suspect the issue is with MacPorts base. Unfortunately, I am not familiar enough to dig further.

~> port info libvpx
Error: Unable to open port: invalid command name "compiler_blacklist_versions._get_compiler_version"
~> sudo port uninstall libvpx && sudo port install libvpx && sudo port unsetrequested libvpx
Note: It is not recommended to uninstall/deactivate a port that has dependents as it breaks the dependents.
The following ports will break: ffmpeg @4.2.1_0
Continue? [y/N]: y
Warning: Uninstall forced.  Proceeding despite dependencies.
--->  Deactivating libvpx @1.8.1_0
--->  Cleaning libvpx
--->  Uninstalling libvpx @1.8.1_0
--->  Cleaning libvpx
Error: Unable to open port: invalid command name "compiler_blacklist_versions._get_compiler_version"

Change History (3)

comment:1 Changed 14 months ago by mf2k (Frank Schima)

See also #59223. It must be the compiler_blacklist_versions portgroup with the typo.

Last edited 14 months ago by mf2k (Frank Schima) (previous) (diff)

comment:2 Changed 14 months ago by TP75

see #59227 including a hotfix workaround for 'libvpx' builds

see comment on commit 9e40a5a "compiler_blacklist_versions pg: use base support"

Last edited 14 months ago by TP75 (previous) (diff)

comment:3 Changed 14 months ago by Aaron Madlon-Kay <amake@…>

Owner: set to Aaron Madlon-Kay <amake@…>
Resolution: fixed
Status: newclosed

In 0935a2273ec97041947316e6ed825b484337cf98/macports-ports (master):

libvpx: use base support

Fixes breakage caused by removal of function in
9e40a5a4b0d4b5221b55a83642762cf613863ff6/macports-ports

Fixes #59226

Note: See TracTickets for help on using tickets.