Opened 14 months ago

Closed 13 months ago

Last modified 11 months ago

#59285 closed defect (invalid)

invalid command name "compiler.command_line_tools_version"

Reported by: micrology Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc:
Port:

Description

I did a selfupdate:

--->  Updating MacPorts base sources using rsync
MacPorts base version 2.5.4 installed,
MacPorts base version 2.6.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is outdated, installing new version 2.6.1
Installing new MacPorts release in /opt/local as root:wheel; permissions 0755

and then a

sudo port upgrade outdated

Half way through, it threw an error:

Error: Unable to open port: can't set "compiler.blacklist": invalid command name "compiler.command_line_tools_version"

I am using MacOS 10.14.6, using Xcode 1.1 and have installed Command Line Tools, accepted the Licence and launched XCode.

A google search for compiler.command_line_tools_version fails to find anything useful.

Change History (8)

comment:1 Changed 14 months ago by micrology

False alarm: It sems that the selfupdate to 2.6.1 did not complete (although it did not produce an error message). Repeating the selfupdate made it complete successfully and a subsequent 'upgrade outdated' succeeded without error.

comment:2 Changed 14 months ago by mf2k (Frank Schima)

Keywords: compiler.command_line_tools_version removed
Resolution: invalid
Status: newclosed

comment:3 Changed 13 months ago by srogers (Steve Rogers)

FWIW, I had the same issue upgrading to 2.6.2 - selfupdate ran without errors, but upgrade failed with the error above. Re-running selfupdate resolved the problem.

comment:4 Changed 13 months ago by rpspringuel (Fr. Samuel Springuel)

Resolution: invalid
Status: closedreopened

I'm getting the same error but rerunning selfupdate is not resolving the problem. I've done that 4 times now and each time it still thinks that 2.5.4 is still installed. Any other ideas for possible solutions?

comment:5 Changed 13 months ago by jmroot (Joshua Root)

Resolution: invalid
Status: reopenedclosed

That means that selfupdate is failing. Run with -d (sudo port -d selfupdate) to see the reason. If that reveals that there is an actual bug, please open a new ticket against base.

comment:6 Changed 13 months ago by leungks1

Resolution: invalid
Status: closedreopened

I had the same problem in updating the Macports base. It was solved by agreeing to the Xcode EULA (End User License Agreement) by running "sudo xcodebuild -license" in a terminal.

comment:7 Changed 13 months ago by mf2k (Frank Schima)

Resolution: invalid
Status: reopenedclosed

That's still a user issue and nothing needs to be fixed in base.

comment:8 Changed 11 months ago by eflister

this shouldn't be closed, i ran into the same thing. it's not a user issue, base should be fixed so that selfupdate doesn't silently fail. i opened new ticket https://trac.macports.org/ticket/59916

Note: See TracTickets for help on using tickets.