Opened 9 months ago

Closed 6 months ago

Last modified 6 months ago

#60035 closed defect (fixed)

llvm-9.0: sh: pkg-config: command not found

Reported by: ryandesign (Ryan Schmidt) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: larryv (Lawrence Velázquez), kencu (Ken)
Port: llvm-9.0

Description

llvm-9.0 uses pkg-config in its configure args but does not declare a dependency on the pkgconfig port, resulting in the error message:

sh: pkg-config: command not found

See #60034 for a log showing this.

Please also check if other llvm-* ports are affected.

Change History (4)

comment:1 Changed 6 months ago by kencu (Ken)

Indeed so. Most of them need this added. Thanks.

comment:2 Changed 6 months ago by kencu (Ken)

Resolution: fixed
Status: assignedclosed

In b94ef94c045b88e597ecab6e5b3229e6b6d09a3b/macports-ports (master):

llvm-5 to 9 and devel: add pkgconfig build dep

has always been needed
no revbump now -- revbump coming shortly
closes: #60035

comment:3 Changed 6 months ago by jmroot (Joshua Root)

It didn't actually need pkgconfig or it would never have built on the buildbot.

comment:4 Changed 6 months ago by kencu (Ken)

help me understand better please, I think this was different.

Jeremy wrote this in an unusual way, with backtiks in the the cmake configure line to drive pkg-config for the ffi flags.

without pkg-config, there was always a warning right after the cmake config line that pkg-config was not found, but never an error, as above.

so I think the backtik line just produced an empty string for the ffi includes when pkg-config was not found, but it never actually errored. But it is used to generate the proper includes if it is found ( the warning is gone when pkgconfig is added).

Last edited 6 months ago by kencu (Ken) (previous) (diff)
Note: See TracTickets for help on using tickets.