Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#60287 closed defect (fixed)

boost @1.71.0 does not build: clang: error: unknown argument: '-fcoalesce-templates'

Reported by: i0ntempest Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: michaelld (Michael Dickens), jowens (John Owens), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: boost

Description (last modified by i0ntempest)

It seems that boost can't choose the right compiler or can't get the compiler version right, so it ends up adding an arg that the used compiler doesn't recognize. I added compiler.blacklist clang and now it builds, but I'm not sure it's the best thing to do so I'm opening a ticket. Build log attached.

Attachments (1)

main.log (411.1 KB) - added by i0ntempest 7 months ago.

Download all attachments as: .zip

Change History (10)

Changed 7 months ago by i0ntempest

Attachment: main.log added

comment:1 Changed 7 months ago by i0ntempest

comment:2 Changed 7 months ago by i0ntempest

Description: modified (diff)

comment:3 Changed 7 months ago by i0ntempest

Description: modified (diff)

comment:4 Changed 7 months ago by michaelld (Michael Dickens)

I'm betting you're correct. We have a PR for this ( https://github.com/macports/macports-ports/pull/6726 ) ... but just for older OSX right now ... I did raise the question of whether it should just be applied globally & this issue seems to indicate "maybe so" ...

Last edited 7 months ago by michaelld (Michael Dickens) (previous) (diff)

comment:5 Changed 7 months ago by jowens (John Owens)

Cc: jowens added

comment:6 Changed 7 months ago by i0ntempest

Yeah, this should be applied until the upstream fix is released... or maybe we can just use that fix in the patch file? One more thing, can you pls make boost to build using python38 by default? So that dependent ports can all default to python38.

comment:7 Changed 7 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:8 Changed 7 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Owner: set to MarcusCalhoun-Lopez
Resolution: fixed
Status: newclosed

comment:9 in reply to:  6 Changed 7 months ago by michaelld (Michael Dickens)

Replying to i0ntempest:

Yeah, this should be applied until the upstream fix is released... or maybe we can just use that fix in the patch file?

Patch is merged. When we update to Boost 1.73, we'll remove the patch since it will be integrated.

One more thing, can you pls make boost to build using python38 by default? So that dependent ports can all default to python38.

Looks like Py38 is the current default in the Python PG ... so, yes, I'll update Boost to match. Thanks for pointing that out!

Note: See TracTickets for help on using tickets.